Binance to metamask through erc-20 no funds

Hey everyone!

So I’ve seen many have this issue and it bothers me a lot. So I seen so many fixes but nothing worked for me.

I transferred from Binance through ERC-20 to metamask. I see the transaction that is successful, I tried adding the binance mainnet and tried adding tokens through there and through ethereum mainnet but nothing appears. Also I saw one fix where a guy installed brave browser, connected his wallet and it fixed- not for me. actually from there the transaction history even disappeared.

Txn Hash: 0x9b7b749ed14803e9c2170a56fabe3353d0687d05f079d8386dc18518332ffb45

Wallet Address: 0xf2eb79EC5Eb5db3dAa85b9923de1Bad2830FF5ff

Hey @Aryan23, it looks like there was a transaction of ETH out of your wallet address immediately after your transfer from Binance. Did you confirm this transaction? :point_down:

Hey! So I checked through coinbase wallet and I saw the miner fee for the gas. This is where it went and probably it is no longer available to get back.

Correct, all transactions on the blockchain are irreversible so you will not be able to get the tokens spent on gas fees back.

Crazy… just on gas that much.

Yea, gas can get very high at times :sweat_smile:

Unless you need the transaction done immediately, it’s usually better to wait for gas prices to be lower. MetaMask shows an estimated gas fee before every transaction, and, you can also check beforehand on gas tracker tools like this one:


This topic was automatically closed after 30 days. New replies are no longer allowed.