Brave Browser LDB files will not work in MetaMask Vault Decryptor

I have a friend who didn’t back up their seedphrase… and MetaMask crashed on his brave browser.

I have been able to complete a data recovery and have located the .ldb files in question.

Tried to run them through the: MetaMask Vault Decryptor , however just received a message : Can not read vault from file

I figured it was just corrupt so I thought I would test with a healthy .ldb from my pc with a working meta mask wallet to… I received the same message… so either the decryptor is buggy or the .ldb files that brave create are different and the decryptor cannot read them at this time…

Has anyone had any success with Brave Browser and the MM Vault Decryptor?

FWIW I just tried the Vault Decryptor on my currently running MM installation (Edge browser in my case) as a baseline to troubleshoot a problem on a different computer and I got the same error from the vault decryptor tool with my 000005.ldb file. Is the tool still working properly, did something with the encoding change and the tool needs to be updated?

Hey Mike,

So, you need to modify the data in the .ldb file :

  • you have to edit the beginning {"???'<0x04>" to {“data”
  • and delete all \

Try that…


Hi, thanks for the tip. So there were two problems. The first was that my vault was not stored in the 000005.ldb file like the documentation mentions, but instead in 116078.ldb. So the part where it says to look for a small numbered file with leading zeroes is incorrect. Second problem was what you mentioned, the tool can’t read the file as is. So, I followed your suggestion and the instructions to copy paste the keyring section out into a different file and make all the modifications specified. Typing in “data” correctly, “iv”, “salt” - deleting the backslashes and other cleanup specified in the article - so that it looked like the example. I was then able to copy/paste that string into the vault decryptor tool and it was able to function properly to decode my pass phrase.


Thanks for the info @PhantomMike, I’ll pass this along to the team


Hey @PhantomMike, was your 116078.ldb file the only one there, or did you also have another file like 000005.ldb?

Was this also with Brave browser?


Hi, yes I did have a 000005.ldb file, and no this is not Brave but Edge browser.


This topic was automatically closed after 30 days. New replies are no longer allowed.