Lost seed phrase, trying to use vault/decrypted browser method, found log files but cannot find 'vault' in 000008.ldb to get data i need o find recovery phrase

Lost seed/recover phrase, trying to use vault/decrypted browser method, found log files but cannot find ‘vault’ in 000008.ldb to get data i need to find recovery phrase, anyone help me? im using brave brower. Metamask randomly reinstalled itself so locked out without recovery seed phrase

2 Likes

@Luigi please can you help, your comments on anohter thread got me this close to finding what i need, but when i search using atom i cannot find the word vault, or salt to try get the data i need

2 Likes

Hi @krustydj sometimes that file looks like this :point_down: try find word: keyr

Delete all :point_right: \ but don’t delete :point_right: /

This file should contain your ETH address :slightly_smiling_face: but do not search a complete ETH address (try to find the first or last 5 characters your ETH address)

5 Likes

HI @Luigi, thanks for replying! I had no luck searching for the word keyr, or key to write in the word data! also no luck finding my eth address, first or last few digits! its so annoying, is there anything else i can do! ive got 2 different .lbd files 000005 & 000008, also a 000007 log file! Any ideas why the code im supposed to copy and paste into ‘inspect’ in brave browser doesnt work also? would be so much easier! (the code below is the one i mean. ) (maybe it cus im using brave browser but says on the metamask support page that itll work) i know my password just need to find the correct data to use the decrypt system!

chrome.storage.local.get(‘data’, result => {
var vault = result.data.KeyringController.vault
console.log(vault)
})

this is the reply i get instead of the data needed

Uncaught TypeError: Cannot read properties of undefined (reading ‘local’)
at :1:16

is it because the disk is somewhere else? or something else you understand? i ont understand coding very well atall! thanks again man

1 Like

This command :point_down: also works on the Brave browser :neutral_face: but it won’t help you… when you created another wallet.

chrome.storage.local.get('data', result => { var vault = result.data.KeyringController.vault console.log(vault) })

Sometimes the data can also be in .log files :slightly_smiling_face:
Check all files: .log and .lbd

2 Likes

Hey @krustydj, welcome to the MetaMask community! :fox_face:

Do you also have any other devices that you have used your MetaMask wallet on?

1 Like

@nakedwinnie I’m trying to help him :slightly_smiling_face: he use the Mac OS + Brave browser and Metamask wallet.

But when he opens the file .ldb doesn’t see any words like: data, vault…

Strange :see_no_evil: as if they disappeared.

Data could be corrupted and files lost :slightly_frowning_face:

YES He had some browser issues :neutral_face: and the data is probably corrupted.

Hoping he used MetaMask on another device also :pray:

@krustydj?

Hi @Luigi
Did you try grep on terminal?

Step 1. Open the Security & Privacy Preferences pane of System Preferences and select the Privacy tab.

Step 2. Unlock the interface by clicking the lock icon, choose Full Disk Access from the list of services on the left, and drag and drop the icon for Terminal into the list.

Step 3. Launch Terminal.

Step 4. Type grep -w \"salt
or grep -w vault
or grep -w keyr

Hope it helps! (I do not use MAC :rofl:)

3 Likes

Hi @MomOfTwins I also don’t use MAC :rofl: I use Windows XP (kidding)

No no :slightly_smiling_face: i haven’t tried this.

2 Likes

HI, sorry for the long reply & thanks for trying to help! I didnt have metamask on any other device sadly :no_mouth: it does seem like its corrupt or encrypted (n)

Thank you for your comment, sorry for the long reply! I havent tried this but will try this within the hour and will update you, any other ideas please let me know! Luigi has been great at trying to help me, but the files either seem corrupt or encrypted. Thanks again

Sadly doesnt seem to do anything when typing in these codes ;(

Hi @krustydj ! Try in terminal tmutil listbackups to see if you have TimeMachine BackUps.

Thanks again but no directory for host comes up

Also in reply to your previous message i cant actually find the data to copy and paster into the decryptor, seems to be encrypted or corrupt

:face_with_monocle:

@krustydj
Hmm… I imagine you tried DisckDrill olready with @Luigi

If you didn’t not:

Grant Full Disck Access (you can watch this vidoe for more information how to do this [Disk Drill Data Recovery Tutorial for Mac - YouTube](https: //www . youtube . com/watch?v=sg6ZQ6ut2jY)), lounch DiskDrill and choose Deep Scan. It will take a while. Once finished,

  1. tape “nkbi” in search
  2. navigate to the log and lbd files in nkbihfbeogaeaoehlefnkodbefgpgknn folder and select them
  3. do the same for other chrome sessions if you have them
  4. recover files
    Now you can pick up the oldest ldb or log files and decrypt the vault data from them.

3 Likes

Hi @krustydj ! Happy you are found the vault data! :slightly_smiling_face:

it happens when your password is incorrect. Try all your usual passwords as well as CapsLock activated. Hope it helps.
image