Browser loost phrase info, dont let me put it back

Hello, my browser lost prhase data, I have tried reinstaling the wallet, but as soon as I start typing in the last word, it shows : Invalid Secret Recovery Phrase and never activate the buttom to import the wallet, I am 100% sure phrase I putting in is correct, but wrowser dont even let me finish type it in, tryed in firefox and chrome, same problem.
thx for the help

1 Like

Hello @jhonyy , welcome to the metamask community

Have you tried to log in with another device ? May be a mobile device . Or import your account through other means ?


Hi @jhonyy ,

Confirming you’re actually typing in all the words (including the last). My apologies if this sounds like a silly question but just making sure you’re not stopping since you get the ‘invalid’ message.

Also confirming you’re typing in everything lowercase? And are there any words that maybe you wrote down with incorrect spelling?



Hello, the same happened to me once when I was importing my account via the seed phrase. I thought every word I typed was correct, and I had no idea why I got the error that the secret recovery phrase was invalid. Then I further investigated and noticed that I misspelled only one word by switching only two letters (for example, I typed i before e instead of typing e and then i). I suggest you make sure that you correctly imported every word. Specially pay attention to the middle letters. When the first and last letters of a word are correct and only the middle letters may be misspelled, it causes a kind of visual error, which is why I thought I entered the words correctly. That “might” be the case for you as well.


This topic was automatically closed after 29 days. New replies are no longer allowed.