Can't access my ETH. MM wants a QR code to generate a sig but I've never used QR codes

About 5 hours ago I created a new account/wallet in my MM Chrome (current build) extension. I sent a bunch of ETH to it. But now I can’t use that wallet (I have 4 wallets in that extension) and this is the only one that, when I look at the list, it has a little “QR” in a circle next to it.

When I try to transfer the ETH onto a different wallet in my list, I’m shown a QR code (never seen that before) that I supposedly have to scan to get a signature. Scan it with what? I don’t have any hardware wallets or anything else I use with MM.

I also can’t view my private key, the option is not offered when I look at the account details, unlike the other 3, and I can’t even add the wallet to another MM install I have on a different computer, with the same other wallets, as I can’t get the private key, and when I try to do it with a JSON file, I get a message that says “Not a V3 wallet” and I don’t understand that. I’ve been using MM for a year and a half and have never had something like this happen. I can’t access my ETH and it’s destroying me. I’ve tried everything I can think, but I don’t understand why it wants to scan a QR code to generate a signature, I’ve literally never done that before, and I created this wallet the same way I created every other one and they all work just fine (but don’t show the “QR” in a circle after their names when I look at the list.

Can anyone help me? I’m so upset and confused. And this is a huge deal for me.


Hello @PeculiarHead !
Welcome to MetaMask community )

I need to know a few details:

  1. What is the current version of the extension, how long ago did you install it?
  2. How long have you been using the first three addresses, are there any transactions there? And how long ago did you create the 4th address.
  3. Have you tried scanning the QR code through your mobile device’s camera?
  4. Can u share any screenshots how it looks ? ( You should blur a part of qr code ) :

I look at the list, it has a little “QR” in a circle next to it


The current version of MM is 10.27.0. I installed MM a long time ago, a year and a half or so? The other addresses I work fine and I use for other chains, like Matic, etc.
This 4th address I created about 5 hours ago, using the normal “Create Account” feature, and created it the same way I have created other accounts (wallets).

When I scan the QR code when it pops up saying “Request Signature” with my iphone 14pro it says “No usable data found.”

I’m including an obscured screenshot so you can see what happens when I initiate a transfer, it tells me gas fees, I click “confirm” and then the weird QR code and request pops up (which I’ve never seen before). Thank you for trying to help, it’s all the ETH I have so it’s important to me, and I have no idea what happened as I did everything the exact same way I always do it, and I’m insanely security conscious.


It clearly wants to scan a code from something else, like a hardware wallet like Keystone or something, but I don’t use them, so I couldn’t even have set up the new wallet to use one.

Also, when I clone my MM account on another computer, that particular wallet won’t show up at all, but the others do.


Hmm :thinking: so you see something like this:

Don’t you have a CoolWallet App? :grinning: strangely…
What is the name of the eth account? Account 4 or otherwise?


Yes, that is exactly what I see in both images, including that little “QR” in the circle, but only on that one wallet. I do not have CoolWallet though, no, I’m not familiar with it but if should look at it I will. The name of the wallet is “Bot” but as that can be changed at any time, I don’t pay much attention to wallet names, just the public addresses.

And looking at the link, I’m a but confused as to what CoolWallet does or how it might help me. But perhaps I’m just being obtuse.


Do you do this by pressing the Send button on MetaMask?

Also, is this an imported wallet?


To send the ETH to my other wallet, yes, use the “Send” button (and I’ve tried both using the other wallet’s address (wallet #1 in the same MM install) and also by using the “transfer between accounts” in the MM extension, and both ways result in the same QR popup to acquire a signature.

It is not an imported wallet. It is a brand new one I personally created now, about 6 hours or so ago (the same exact way I created all the others, and using no third party hardware or software that would lead to this wallet requiring a QR code, and I’ve never seen anything like before with MM).


Yes, this is really odd.

Please go to and click the blue Start a conversation button so you can contact the technical support team.


I’m watching now :smile: it is not possible without that card :point_down:
so you didn’t create it that way… no one else could create this account?

Did you rename the eth account to Bot?


OK, thanks. I think I started there and got a bot that very unhelpful, but I’ll try again and specifically look for what I see in your image. Thank you.

1 Like

Yes, I did. I thought it was funny. Is that a bad thing to do? And no one else created the account or even has access to my computer.

It connects you to a bot at first to answer a few first questions, soon afterwards you should be connected with an agent


WEIRD :thinking: no no… you can have any name you want :grinning:

1 Like

Yeah, I just got off with a support agent who deals with third party stuff w/ MM and even he says he’s never seen anything like this before or even heard of it. So they are looking into it and hopefully they can help. Or I’m out a lot of money, which is distressing.

Do you have your 12-Word Secret Recovery Phrase for that wallet? If so you should be fine. You will always have access to that wallet address through your phrase.


I do have my seed phrase, yes, but interestingly it doesn’t work on any other computer if I use it to recover/add that particular wallet. Hence why there’s clearly a bug that they are looking into.

Really weird @PeculiarHead maybe you could sign it with Air Gap mobile app :expressionless:
if you find this eth address in “Address Explorer”


I’m unfamiliar with AirGap, so I’m not sure how an app I’ve never used can help create a QR code when I didn’t use it to set up the account. I know you are trying to help, so I don’t mean to sound disrespectful if that’s how that sounded. Text is a hard medium in which to express oneself sometimes, and I do appreciate that you are trying to help me, thank you.

I wonder how MetaMask wallet created this eth address :see_no_evil:

I’m reading here :point_down: select “Address Explorer”. There you will see all sub addresses of that account and you can compare them to what MetaMask shows you.

But I’m afraid that your address was generated somehow differently :roll_eyes: it would like to do some tests… somehow find this address :neutral_face: but that’s complicated.