Unable to scan QR code for account address in Mobile App

Has anyone had any issues scanning the QR code from the mobile app? I have a handheld scanner, that can scan the QR code address from the Desktop extension, but when I trying doing it from the Mobile app, I can’t get a scan. I tested other QR codes from my mobile device without any issues. I have the same issue when using the laptop webcam, I can’t get a scan from the Mobile MetaMask app, but I can from the desktop wallet (I took a screenshot from desktop and sent it to my mobile device). Any suggestions would be really helpful. Same issue when trying to scan a Rainbow account QR code.

Thanks.

scanner specs: amazon Tera Barcode Scanner Wireless and Wired with Battery Level Indicator 1D 2D QR Digital Printed Bar Code Reader Cordless Handheld Barcode Scanner Compact Plug and Play Model D5100 (can’t include links:

2 Likes

hi @vanes ,

Can you please submit a MetaMask Help Desk ticket regarding this? They’re going to ask what version of MetaMask you’re on, your device type, etc. (and of course, they will never ask for your secret recovery phrase.)

To do this, go to support.metamask.io (or click ‘Knowledge Base’ in the upper right hand corner of this forum screen you’re on) > click the large blue ‘start a conversation’ bubble. It will connect you with a bot at first but as you answer questions, it will file a ticket.

Confirming you’ve got the latest version of MM downloaded and also have tried basics like clearning cache/cookies?

Thanks!

3 Likes

hey @KBeeTheCapybara , I am running MetaMask version v5.3.0 (latest version as of 6/16/22) (927) on iOS. Cleared browser cookies, cleared browser history, issue persists. I also tried to scan the QR code with an iPhone on camera mode. The error was “no useable data found”. I’ve tried on different networks. Dark theme is on.

3 Likes

Thanks for confirming, @vanes .

Can you put in the help desk ticket as noted above, it will help the team dig into the issue. Thanks!

2 Likes

I actually spoke with someone over chat. They said that this feature is not something that is supposed to work… It seems strange that the QR code from the desktop is scannable with phones, but not the mobile app QR code. I’m happy to still create a help desk ticket as I’m not sure that is correct.

1 Like

Heya!

Hm, I’ll inquire and see the scoop! I’ll get back to you once I hear the best steps.

Hey @vanes ,

Got this thought from someone -

Might be worth checking if MM has access to iOS camera by going into Settings > MetaMask > Allow MM to Access Camera (switch on/off/on) > Reboot

Can you give above a try?

Toggled Camera access from on to off. Rebooted. Toggled camera access back to true. Issue persists.

Just so we are on the same page, I am not having issues when scanning the mobile QR code within the MetaMask app, it’s if I’m using the native phone camera app, the scanner as listed above, or my webcam.

I can’t link the Github issue link, but this issue is currently open: Dark Mode - Cannot scan request for payment QR code #4490

  • from the MetaMask-mobile repo
2 Likes

Thanks!

I appreciate all the detail you share, it makes it easy to follow. Will couple your issue with GH link (got it, thanks) and get back to you once I hear something.

2 Likes

@vanes ,

It looks like there will be an update to QR codes with 5.6.0 version release. Once you have this updated, if you still have issues please let us know!

Thank you!

2 Likes