Cant connect Ledger with MetaMask on BRAVE Browser


My MetaMask doesnt see my ledger wallet during connection. I have updated firmware on ledger, updated brave and when I want to connect ledger with MM its stil pending… Ofcourse ledger live was off and ETH App turned on on wallet

Anybody had the same issue? Would be grateful for help

PS. It worked on chrome but dont know why not on Brave…

anybody can help? would be grateful for solution ideas

the same problem, but I’m on chrome and firefox
macbook pro

everything is the same, hope can get help. the ledger can connect to directly, that means browses and ledger nano X is OK.

its strange becuase on my chrome it works… I succesfully connected ledger but strangly not on brave. Same using Macbook Air M1.

Hello exactly same problem

I have encountered the same problem when I switched to Brave. Metamask worked the first time I imported the wallet on Brave. But the next time I logged in, Metamask said my password was incorrect.
I tried logging into my Metamask on Chrome and it [still] works there.
Any help please?