Connect Hardware Wallet not showing my account address

Recently bought a Nano S Plus for my wallet.

I followed the YouTube guides and Ledger/MetaMask guides for the set-up but whenever I get to the part where I am adding my account for ETH, my address isn’t there.

I’ve tried:
Updating everything
Restarting browser
Resetting my MetaMask account
Added ETH to Ledger App tab
Trying to connect with Ledger Live off
Enabling Blind mode on Ledger
Having ETH approved before connecting to Ledger from MetaMask hardware connect
Disabling my firewalls
Opening up MetaMask in expanded view
Force update of MetaMask in developer mode in Chrome
Changed MetaMask to WebHID
Repeated all of the above several times

Anybody have anything else that I’ve missed or could try?

2 Likes

Never mind! MetaMask tech support clarified that the addresses listed are the Ledger addresses that should be used for transfers. MetaMask addresses are the unprotected ones.

That said, I should be using the Ledger generated addresses for transferring my currency.

4 Likes

I got the Ledger Nano S and I use the address that my Ledger gave me, and it have worked just fine for long time.

But I also had some problems getting the Ledger to connect with MetaMask and had to try many times before it worked.

2 Likes

Hello @Onnajy.

Here are 2 articles to help you with hardware wallet configuration and how to use it.

2 Likes