MM bug? Ledger: Account does not belong to connected device

So I connected the ledger nano s to MetaMask and added a new ETH address, where I sent my funds to. But when I try to move the funds out MetaMask is saying that the address does not belong to the connected device.

I have never had any other ledger device and if I try to add another address using my ledger MetaMask shows a different address in the list for the account number that I added previously and sent my funds to. Could this be a bug?

Someone please help, this is all my ETH!

9 Likes

Hi!,

Please check if your Ledger account is already paired with MetaMask? In the wallet extension, please click the identicon in the top right-hand corner and scroll down to see the account in your wallet.

If you have any other crypto wallets enabled on your browser, please disable them and clear your browser’s cache. Please then reboot your browser and try connecting your Ledger to MetaMask once again.

Please ensure your Ledger Live is closed when pairing via WebHID and the ETH app is open on your Ledger device before starting the "Connect Hardware Wallet > Ledger > Continue " sequence in MetaMask.

In addition, check out this article from Ledger for connection issues.

After reviewing above, please let us know if you’re still having issues.

7 Likes

Hi there. Thanks for the quick reply.

My ledger is properly paired with MetaMask. I know for sure because I already tried sending small amounts from other addresses that are also connected to Ledger. The problem is with one specific address which, apparently, was not created properly by MetaMask (as I said before, if I repeat the process for the address in question on a different brouwser/pc I get an entirely different address).

Could it be possible that MetaMask did not request the address from the ledger device using the correct derivation path?

4 Likes

Hi @Swing try to find ETH address it with the help of this guide :point_down: using the Findet site.

It must find this ETH address :slightly_smiling_face: if it was created by your Ledger wallet
and it will show the ETH derivation path :railway_track:

7 Likes

Hi Luigi. Thanks for trying to help.

I already tried Findeth but without luck. Upon further research it seems like the problem could have been due to a MetaMask bug related to associating addresses to incorrect derivation paths, as found on Reddit (I can’t post links, but the post is titled " Bug in MetaMask v10.0.2 when connected to the ledger, causing it to generate address not easily accessible.")

So if MetaMask sent a non-standard derivation path to the ledger device the address won’t be found on Findeth, as this website only looks into a few pre-set derivation paths.

1 Like

Please contact MetaMask support. Go to support.metamask.io and choose ‘Start a Conversation’ this will help you open a ticket:

3 Likes

I am reading :thinking: interesting bug.

Try download here :point_down: the file bip39-standalone.html

Disconnect from the internet :globe_with_meridians:
and try to find yours derivation path :slightly_smiling_face: good luck.

But it would like a better tool :thinking:

6 Likes

yeah thanks, but I won’t expose my seed phrase like that. I’m using a hardware wallet for a reason ;).

3 Likes

Without internet hard :grin: and you can create a live Ubuntu for greater security.

4 Likes

To share, have also passed along this to the team. Will let you know when I have a response!

2 Likes

@Swing this discussion :point_down: is also interesting.

But the tool I see there :smiley: also needs a seed phrase
and your ETH address + :penguin: Linux (without internet)

Derivation Path can also be changed on the myetherwallet page:

5 Likes

@Swing ,

Received a response fro support team, they asked if you would please submit a support ticket so they can take a deeper look. All the threads posted here to Reddit or GH were resolved. Follow the steps above to open one.

Support will never ask for your Secret Recovery Phrase or ask you to input it on a site, form, pop-up window. No matter how legit something may look, never provide it anywhere. Also, support will never ask to connect to your device or ask you to screenshare.

Thanks so much!

3 Likes

Thanks, I appreciate it. It’d be great if they can release a fix that won’t require expose the seed…

1 Like

oh I just saw this reply. I’ll create a ticket, thanks.

2 Likes

@Swing I was looking for a better tool but :see_no_evil: I couldn’t find one.

Try the site https://mycrypto.com/ :grinning:
I read here :point_down: that they have a hardware wallet scanner…

3 Likes

Already did! That indeed appears to be the best site for deriving addresses from custom paths. The problem is that I don’t know which path MetaMask sent to the ledger device, so I could be trying for ages before I find the correct one…

1 Like

I have been chatting back and forth with MetaMask Support for about a week now, but they haven’t been able to help me solve the issue; it’s a process I guess. When/if a solution is found I will share it here for future reference.

4 Likes