Metamask account suddenly gone! Can i still recover my funds?

Hey everyone.

I have a huge problem.

I transferred funds within my MetaMask from Account A → Account B. I’ve seen the funds (1 NFT + $SDL tokens) arrive in Account B.

The next day when i opened my MetaMask, Account B is totally gone and nowhere to be found. (0x12c951e8D4838420e01EB8a0E6eC2bDc44A83249 is the address)

I tried to think, what can i do? I should be able to enter the address somehow, right?

What i tried first was to re-enter my wallet using my secret recovery phrase (12 words). All my other accounts were there, but Account B still not there. Also after adding 40 accounts manually.

I tried searching around the internet for information, but i didn’t find any solution.

It might be that Account B was connected to my Ledger, but i’m not sure. There is no evidence within my hardware wallet that this is the case.

Possible solutions?

  • This is the only secret recovery phrase i created for MetaMask. So it can’t be that certain accounts belong to a different recovery phrase.

  • I’ve tried adding addresses manually when connecting with my hardware wallet. In every possible Preferred Ledger connection type. There’s numerous addresses listed that i can add to MetaMask. I’ve scanned the first 500 addresses but Account B is not listed between them.

  • I don’t have the private key to the address. Only a 12 word recovery phrase to the wallet.

The address can’t just be gone right? I should be able to enter it somehow, right?

I really hope someone can help me or can give me some leads! If you need any additionial information, just let me know. I’ve seen there are lot of people with a similar problem but not quite the same as this. I’ve contacted MetaMask support already, but i’m still awaiting response.

Kind regards.


  • One thing i want to add: i was able to send funds from Account A to Account B, but i wasn’t able to get funds out of Account B. It said transaction failed. No idea why! Next day the whole account was gone.

  • I tried searching 0x12c951e8D4838420e01EB8a0E6eC2bDc44A83249 on Findeth to see if it was connected with my Ledger but it didn’t give any results.

  • I found a topic on reddit (search for Bug in MetaMask v10.0.2 when connected to the ledger, causing it to generate address not easily accessible) on Google. Maybe it has something to do with it?
    If you search for Ledger Nano: MetaMask Address does not correspond to Ledger #6012 on Google you will find an interesting topic on Github as well, which seems familiar.

  • Extra information is that i used an outdated version of Ledger Live during the time of the problem. It was not updated for months, maybe even years. (i couldn’t)

  • When i manually add wallets in my MetaMask, somehow it skips Account 32 (as you can see in the image i uploaded). This might be the account/address which is missing.



Hello @vlindersteen !
Welcome to MetaMask community )

You may check out the following guide:


I’m getting more and more convinced that my problem is the same as this:

Search on Google: " Ledger Nano: MetaMask Address does not correspond to Ledger #6012 "

What if you connect your Ledger Nano to the Live Ledger app on desktop? If you Ledger holds your address 0x12c951e8D4838420e01EB8a0E6eC2bDc44A83249 then you should be able to get access to that address using the Desktop app.


It didn’t work. It’s a deep technical issue i’m afraid.

I don’t know if i’m in the right direction, but i believe my address (and funds) are somehow on a different Derivation Path than it should.

Could it have to do anything with this?

How can i know which Derivation Path my address is on?

If I look at etherscan, I can see 2 transfers into your account. You should have ETH and SDL on you account. Is that right ?

But if you can’t connect your Ledger to the Ledger desktop app, I wonder if it might have something to do with your Ledger.


That’s correct. I can send money to the account, but i can’t access the account from anywhere (and when i still could, i couldn’t send any money out of it).

I’m not the only one with this problem (search for: Ledger Nano: MetaMask Address does not correspond to Ledger #6012) github topic.

Hey @vlindersteen, can you please contact our technical support team at and click Start a conversation about this?

Thank you!

1 Like

Already did.

The guy behind the chat redirected me to open a support ticket. Which nobody answered so far.

I see, thank you!

Someone will be with you as soon as possible, I’ve also let the team know :slight_smile:


Hy, any luck yet? Something similar happened to me a while back …. Has support been of any help at all? :grimacing:


Hey JulTernes, i’m in contact with with MetaMask support now and provided them with some additional information. I hope they put their best technicians on the job. But it’s clear the problem is a deep tech issue which isn’t solved easily unfortunately.

First i didn’t know where to start with this issue, but i found some information on github that might be useful for you. Search for these topics google, since i can’t post any links:

  • Ledger Nano: MetaMask Address does not correspond to Ledger and can’t move funds #10875
  • Ledger Nano: MetaMask Address does not correspond to Ledger #6012

I saw Dan Finlay was looking into the problem as well, but i don’t know if he found any solutions.


If you can’t get your Ledger to work with the Ledger Live desktop app and MetaMask, I still think that it has something to do with your Ledger Nano device. I hope you get help from the technical support team, but I would also try to contact Ledger support.

I can’t post link from outside this forum, but try to search for " Ledger Solving a MetaMask connection issue", there might be some help there on the Ledger support forum you can use.


Thank you.

It more and more seems that the problem has something to do with Derivation Paths.

1 Like

Hi @vlindersteen I see :face_with_monocle: that you also wrote on github page:

You tried that tool? :point_down:

maybe it could find the derivation path…

For it to work you need Node.js and NPM on Windows:

Next step:
Installs ethereum-cryptography :point_down: write a command
npm install ethereum-cryptography

Open file recoverFunds_manypaths.js and edit the lines 35 (targetAddr) and 37 (mnemonic)

Disconnect the computer from the network and you can try it :crossed_fingers:

You don’t have to type your 24 words right away :slightly_smiling_face: generate 24 words + eth address here: and you can test if it works.


Hey Luigi,

Thank you this seems very promising. It’s not easy for me to understand but i think i’m getting somewhere.

However, after hours of trying, i think i’m stuck now.

I tried running the scripts but i got a message like MODULE_NOT_FOUND.

At the bottom of ApacheSub github page it says:
“If you do not have networking enabled, you could install the dependencies on another machine and safely move the node_modules folder or get the files from github/ethereum/js-ethereum-cryptography. Please note you might need to manually get the dependencies for that library aswell which is otherwise done by npm.”

I don’t exactly know which files i’m missing now. Please let me know if you have an idea of where the problem might be! Thank you.

1 Like

I knew it wouldn’t be easy :sweat_smile:

When you installed Node.js you ticked this :point_down: box?

I will have to try it on my PC :slightly_smiling_face: on my crazy Ubuntu :grin:
If you want :writing_hand: write me on my telegram nick :slightly_smiling_face: you can find it in my profile.
This will be up for a long debate :smile:


Hi @vlindersteen you have to open the Terminal in the folder bsc recoverfunds extension-main

and then write the command :point_down: npm install ethereum-cryptography

In this step :slightly_smiling_face: have the internet turned on.

The MODULE_NOT_FOUND error disappears
but another problem appears :sweat_smile: I love JavaScript hehe


Yup installed Chocolaty as well. I’m proceeding now with the steps you presented in your last post.