I urgently need help

Hi i have been waiting for such a long a long time for my address to be relinked to my wallet and urgently need someone to contact me. I got the confirmation that the wallet was relinked and now on my end i cannot access the funds. Please can someone assist me.

hey @user3815 ,welcome to MetaMask community.
I don’t quite understand what you mean, can you provide more detailed information?

  • What dapp are you using?
  • What operation do you want to do?

Be careful not to reveal your seed phrase / private key.


what is dapp?
i need the swap to show on my end it is still showing me my old address still and not the swapped address

Hi friend. You’re gona have to be more detailed and precise in your explanation for us to be able to help you. We look forward to hear from you again so that we might help you out!

Note: never share your private key or seed phrase with anyone. The MetaMask team will never contact you.


I am unable to even see my crypto. My Meta Mask is not showing ledger addresses where my tokens are. I know I am using the correct hidden wallet passphrase but none of my ledger wallets with the crypto on are showing. I’ve potentially lost a fair it of money and am prepared to offer a reward for any help. I basically sent the crypto to my OG wallet (with Pin) and I then sent some more to my hidden wallet attached to pin and its not there - I have made sure I have added the token into my MetaMask but when I connect my ledger neither of the ledger wallets show. I have the wallet addresses that i sent the crypto to from kucoin and the tokens are still sat in the account - i just cant get the ledger wallet they are on when i connect my ledger. Very frustrating.

1 Like

Hi @Mashster try this:

Thanks so much but it says UTF not supported. If you can help me get this back ill give you some crypto. I am trying to find the wallet with Findora on. I have the wallet addresses and can literally see the tokens sat there on chain. I keep trying the find eth tool and make sure i am on the eth app but it doesnt work.

I can share my wallet addresses where i sent the Findora if it helps.

U2F not supported? :thinking: try another browser

I am happy to share the Findora wallet addresses. I think there has been a bug as I know the passphrase to my hidden wallet and am baffled why the wallet addresss doesnt show when i attach my ledger. Grrr - thanks for helping out. Ill def give you a reward if you help me locate it.

Your eth address won’t help me :neutral_face: and I don’t have any other ideas yet.

1 Like

Ok thanks for trying, I cant get the find eth to work as it just keeps loading saying “connecting” - I appreciate your help though - very kind of you indeed. Looks like thats about $2500 lost - and I am 99/9% certain its not user error. Anyway it is what it is.

Oh 2500$ you have to find it :neutral_face: don’t you have another computer there? This findeth site is also recommended by oficiall ledger page. Mostly it works without error.

Another option :point_down: download BIP39 tool

PS: try it only on a computer without internet or on an old mobile phone without internet.


Thanks I know its so annoying as I just know its not user error i.e. I know I haven’t put in the wrong passphrase. I keep trying the find eth site - but it just keeps loading saying “connecting” and ive tried various browsers. Another hurdle for me DOH. I will try a different computer - thanks so much for your help. Ill have another go tonight on my Dad’s computer. Very very frustrating indeed. I can even see the findora crypto on the wallets i sent it to from kucoin - I just cant find the damn wallets on my ledger.

I dont suppose you know how to use the BIP 39 tool? Ill have a google but not that tech savvy. Thanks again

:one: Here you can download the bip39-master.zip file :point_down:

:two: You unzip it to your desktop and disconnect the computer from the internet :smiley: for better security or use some live usb linux: How to create a Tails Live USB - iFixit Repair Guide

:three: Open the file bip39-master - src - index.html in some browser

:four: BIP39 Mnemonic is your ledger recovery phrase

:five: BIP39 Passphrase (optional) is the word you used to create the your eth address

:six: Coin - select Ethereum :smiley: when you did not use ETC by mistake

:seven: All the way down, you can see Derived Addresses your eth addresses and private keys

Good luck :crossed_fingers:

1 Like

Many thanks - but would it work for Findora as I dont believe thats an eth token. Once ive found the derivation path i will still need to know the passphrase to get in I guess - just trying to work out what the benefits are - as I can see where my findora is. I think ill transfer all of the crypto off the ledger and then at least there won’t be any on there to steal should it go wrong.

1 Like

To clarify, you sent the tokens to your Ledger wallet? Have you tried Ledger Live? What happens when you try another browser?


It’s about finding the eth address… when you know the derivation path, you can use it on sites like MyEtherWallet or MyCrypto :slightly_smiling_face: but it would be best if you could use the findeth site.


Thanks Luigi, but what can i do when i have the derivation path as I know the wallet address already? Many thanks - sorry im not that tech savvy

1 Like

Try https://mycrypto.com/ + Ledger only test whether it finds the eth address… :smiley: still you couldn’t connect to the findeth site?