Ledger Nano S + Metamask ETH adress is missing

Hi everyone, i made this account a couple a days ago because i have some issues with accessing a adress on my wallet.

this is the first time it happening since i bought my ledger in 2018 from the ledger website.

So, less than 36 hours ago, i connected my ledger to metamask (connect via hardware) and choose ledger as i have a ledger nano S.

I then was shown a list of adresses, and choose one which i prefered. it was a couple of clicks on “show next adresses” it then got connected to my metamask and i procedeed with transfering funds in.

Now the problem…

when i try to transfer them out, it doesnt work. no signal gets sent to my ledger promting me to press to confirm transaction.

i am using a brave browser, so i know i need to use ledger live websocket to be able to sign transactions.

However, ledger live cant find adress either.

i even changed settings in ledgerlive from custom gap (20) to (999) yet it does not find the adress.

So i connected to MEW, and have been looking through 3000 adresses each in both legacy and ledger live adresses. i only clicked the next button 5-6 times meaning it can be more than number 50 or so.

I also tried using mycrypto aswell as their desktop application. Nothing.

FINDETH website did not find anything either.

I simply cant find my adress:(

I have never used a 25th word or anything like that. I KNOW this for a fact.

I only have 24 seedwords and a 8 digit pin since day one, and this is the first time this has happened.

I am very scared that somehow ive lost control over my adress and funds and i dont know what to do.

In metamask it says (legacy hardware 20) next to that very adress that i picked from the list when i first connected it to metamask. so it must have been generated by my ledger nano S. I also believe the number 20 means its the 20th adress in the list of adresses.

I tried to recreate this issue by choosing a new adress, but everything works like it before this everhappen. i also see all the adresses i skipped by before actually choosing this very adress that has now gone missing.

I also made a post in ledger reddit, but so far no solution.

Please help me.

Hi, yes all the funds are sitting there on the adress safely.

ledger nano S. latest firmware and latest eth app.

this sounds like a scam, so no thank you.