Didnt recieve my $TEL on KuCoin

Hello,

Im waiting more than 24hours at this moment and still didnt recieve my $TEL.

The transaction Details is success… I dont see it anymore in my MetaMask and not in KuCoin… where can I see the status!?

Please help…

Hi @CryptoNL14 and you added a TEL token to the MetaMask :fox_face: wallet?

Open :point_down: and click on fox :fox_face:

Yes… using it since couple of weeks… also staked some TEL via QuickSwap and TelX etc… everything worked…

Dont know if it helps to give you my; Transaction Hash ?

You tried log out out of metamask and log back?
Page https://etherscan.io/ displays the correct amount?

Maybe try this :point_down:

https://metamask.zendesk.com/hc/en-us/articles/360015488891-How-to-reset-your-wallet

BUT first securely save and store your seed phrase and any private keys you have imported to your MetaMask wallet, then please try resetting your account by going to Settings - Advanced - Reset Account.

Still didnt work… also trying to contact KuCoin but didnt work atm…

I’m running out of tricks here hehe :grinning_face_with_smiling_eyes: and https://etherscan.io/
displays the right amount TEL tokens?

Well… I see now… I used the wrong network I gues… used the MATIC… dont know what to do now…

You need to add a Matic network + TEL token :point_down:

Token Contract Address: 0xdf7837de1f2fa4631d716cf2502f8b230f1dcc32

I have that…

Can I post here my polycon transaction hash? Dont know if thats allowed? Maybe you see something that is wrong?

YES you can send transaction hash :slightly_smiling_face:

This transaction is OK :slightly_smiling_face: but I only see one transaction at this address.

Yes. From my Metamask to my TEL KuCoin Adress.

Kucoin supports only ERC-20 Telcoin (TEL) tokens :point_down:

You need to contact Kucoin support
https://support.kucoin.plus/hc/en-us/requests/new

Thanks! Direct contact with KuCoin now :slight_smile: