Does Metamask support WalletConnect v2.0

Does MetaMask support WalletConnect v2.0? If not, is it on the roadmap?

2 Likes

I believe it should be. Have you checked out the MetaMask dev docs? There is a section for best practices, using WalletConnect, and deep linking. If you’re still having issues after checking this out, let us know.

1 Like

It is unclear from the documentation if it is v1.0 or v2.0 WalletConnect that is supported. The link to WalletConnect within the guide mobile-best-practices under the header “Using WalletConnect” in the documentation points to v1.0 - suggesting that perhaps only 1.0 is supported.

1 Like

hi @kaylaatkrikey I’ll find out and get back once I know!

3 Likes

Hi @kaylaatkrikey ,

WalletConnect 2.0 is not currently supported. See this update here from team: