ETH to Polygon Swap - MATIC Balance ZERO

Hello,

New user here so I’m likely the cause of my issue.

Last night, in an attempt to buy an NFT on Polygon, I was prompted to swap ETH to Polygon, so I accepted the swap. My ETH balance was debited, and after the Polygon network was visible, my MATIC balance remains at zero.

I’ve looked at possible solutions, i.e. adding the MATIC token to my ETH Mainnet, but it still showed up as zero. I tried swapping the Polygon back to my ETH using a bridge, as the Polygon is showing in my Opensea wallet and on the bridge site, but for whatever reason, there is no balance in MM.

I’m surely doing something wrong, but am learning.

If someone can help me find out how to have my MATIC balance reflect the transaction, I would love to be able to bridge back to ETH as I no longer want the NFT as I believe it to be a fake - which I fear may be my issue.

In the hash below, I see that this looks to have swapped into WETH. Again, my noobiness isn’t allowing to me to see the issue here, but it does say that the swap carries with it zero MATIC value. That’s concerning.

Please help.

Polygonscan:
0xf1ed7982d3f394c0ecc0752dcf078bf56d1e485154ca8663e3c35fd487f37bdf

Etherscan:
0xddac7142f0859ad0fb83ebf9ae261da1f09be3e9fc5325ec8941679ca5b8ec65

7 Likes

Hi!,

I can see you have WETH in your wallet address. Have you added WETH token symbol to your wallet? Look for WETH address following methods below -

See below, I have pasted this info from this post How to View Your Custom Tokens in MetaMask

Adding Custom Tokens to MetaMask Wallet Using CoinGecko

Another way to add tokens to your wallet is by using CoinGecko . Head to the browser, search for your custom token, click on the Fox head logo, and it will be added to your wallet.

  1. Open your in-app browser
  2. Search CoinGecko
  3. Search for your custom token
  4. Scroll down and retrieve the token’s contract address
  5. Click the MetaMask fox logo
  6. Select “Add Token.”
  7. Voila! Your custom token should appear in your wallet alongside your other tokens.
5 Likes

Sorry, also wanted to add, using the bridge just carries your ETH over from ethereum mainnet to polygon network, you’d still have to swap your WETH for MATIC if you wanted it. Since you don’t, you can bridge that WETH back to ETH on Ehtereum Mainnet. You may be new, but you knew that bridging was a key - so that’s awesome!

2 Likes

Lastly, here are some good articles from Knowledge Base thought I’d share for anyone coming into the thread -

4 Likes

Thank you so much for the info and the time you spent…

I’ve added the WETH token to my ETH Mainnet, but nothing showed up. What you’re saying is that I need to add the my WETH’s Custom Token Address in order to retrieve the asset? Sorry again for being so new :slight_smile:

Thanks again…

3 Likes

Also, I’m struggling to find my custom token symbol. Can you help with that?

2 Likes

Hi @Volksball is this your MetaMask address? :point_down: I see there 0.05 WETH

Switch to the Polygon network

polygon

Open: https://www.coingecko.com/en/coins/weth
and click to MetaMask icon :point_down: for Polygon POS
weth

2 Likes

Thanks for you help, Luigi.

I tried adding Polygon to my Polygon Mainnet, but it said that it wasn’t supported. When I did the same with WETH, it added the token and I new see my .05 WETH there. Hoping that isn’t an issue with bridging back…

2 Likes

No no Steven :slightly_smiling_face: that’s all right and now you can send WETH back
to the Ethereum mainnet :bridge_at_night: using polygon bridge.

2 Likes

Thanks for your help. I’ve bridged back the WETH back to ETH last night, and it seems to have been debited from my Polygon, but is not in my ETH yet. Can you see where it ended up? The Tx info seems correct, but I may be missing something. Thank you.

0x4ec7bb2e9bfa656b5dfedefbb32a5c27407dfb102a8bb73fc486fbaffb7d182c

Polygon cross chain is relatively slow. Sometimes it takes several days to arrive. We generally use the third-party cross chain to complete the cross chain operation faster

Ok, thank you. So based on the Tx Hash that I attached in my previous message, the transaction was done correctly and I should see the asset added back to my ETH balance on Ethereum Mainnet, but possibly in a few days?

Yes, it’s very possible, because a week ago, the same user response arrived across the chain through polygon for a few days

Thanks. But it shows that my transaction was done correctly? Sorry for all the questions, but I understand that it is very easy to make a mistake in these processes. I’m just trying to establish that I’ve done the transaction correctly.

@Volksball the transaction is not complete :point_down: you can check it out here

https://bridge-explorer.polygon.technology/tx/0x4ec7bb2e9bfa656b5dfedefbb32a5c27407dfb102a8bb73fc486fbaffb7d182c/withdrawals

I’m reading here :point_down: transaction fee 63$ :see_no_evil: oh that’s stupid

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.