ETH to WETH swap keeps failing even after I have reset everything. Anyone know how to fix?

I’ve reset my wallet and also re-installed the chrome extension etc but keep getting this error.

I’ve even tried upping the gas but it just fails every time, I cannot even send WETH to another wallet.

I’m still able to place bids but WETH token does not show up in my wallet unless I add it, then it disappears again.

Any ideas?

1 Like

Try different browser :face_with_monocle: Firefox

1 Like

Or try the brave browser,

Welcome to metamask community


I’ve tried Chrome and Brave so far but can try Firefox too

Try :slightly_smiling_face: and what error does it show you? Do you have enough ETH?

{ethjs-query} while formatting outputs from RPC {"value ; {“code”:-3200,“message”."replacement transaction underpriced}}’

Yeah i have plenty of ETH and have tried overpaying gas etc

Firefox did not work either so I don’t think this is an extension error. I have even tried using a website tab instead of the extensions and same result.

I’m thinking either there is a problem with my account or there is a network problem with WETH right now?

Really weird :smile: You also tried the metamask mobile app?

Try on and off Advanced gas controls

Don’t use a VPN tunnel?

Have you ever tried to clear the cache and restart your computer?

Just tried mobile app also. Still no joy

worth a try but neither of these things worked. Thanks for helping

I recently connected my wallet to IMX last week. Would that have anything to do with this?

I really don’t have next idea :smile: Try used your metamask seed
in the Trust Wallet application and send WETH away.

This is the first time that this situation has occurred. There is no better way. As @ Bobby said, use your private key to import and transfer out your coin in other wallets


Etherscan seems to show I have 2 pending txns, although they do not show in my wallet. How can I clear this?

Try Method 2: Custom nonce

I would do this but there are no transactions in my wallet.

I see the transactions in etherscan but they do not show any nonce so I’m not sure how I could replace them.

If there was a way, I guess I’d just need to set a higher priority fee to overwide them?

thanks for the idea. I just imported into Trustwallet but I still cannot send.

Message says:
replacement transaction underpriced

Watch some videos on youtube:

Send me Transaction Hash pending transaction.


Thank you I watched that and finally managed to shift it after also adding a higher priority fee! : )
Have a great weekend