[ethjs-query] while formatting outputs from RPC ‘{“value”:{“code”:-32000,”message”:”replacement transaction underpriced”}}’

So there are a lot of topics about this but I did not find a solution.
First I was trying to swap tokens in Sushiswap and Pancakeswap and I was getting this [ethjs-query] error. I tried to increase the gas price, did not help.
Then I tried to swap in MetaMask, got the same error, and tried more times. And now I have swaping transaction stuck (transaction id from MetaMask 0xa34f7ef77e794e1d54b33eebe6347ed26416526a9e2239c1ebee0bd087b66002)
If I try to cancel getting the same [ethjs-query] error if I try to speed it up same, even when I enter a high gas price.

So I update MetaMask, and was reading this article: https://support.metamask.io/hc/en-us/articles/4402538041869-Error-ethjs-query-while-formatting-outputs-from-RPC-transaction-underpriced-error-
I did not find advance gass control option in my advance settings

Also, I did check my Polygon network configurations, looks correct.

And I can’t create a ticket (Logged in) as it is not active for me:

1 Like

Hello @user2170, welcome to the MetaMask community,

On which network you got the error?

Is this transaction on the Polygon network? IF yes, I could not find the transaction on Polygon scan. If it is on Polygon network, then check your account on the Polygon scan, if the transaction is not seen on the explorer, then try to clear the account activity and nonce data.
Settings> Advanced> Clear activity and nonce data

Please refer to the following article.


First of all thanks for the prompt reply.

1.On which network you got the error?
On Polygon
2. Clear activity and nonce data
I did that and it helped to remove the pending transaction, but still getting the same error when I try to swap tokens.
3. Please refer to the following article.

I turned off Adblocker and now I can start a conversation. Should I do that or we could try to fix it here on the forum and others will also be able to find the solution later?

1 Like

Changing the Polygon network RPC may help you. You can do it via chainlist. Remove the 2 spaces I inserted in the link.
https:// chainlist. org/
Click the arrow below the the Polygon network box on Chainlist. There you can find a list of RPCs. Choose one at the top of the list and add it to your MetaMask wallet.
The following article is related.

Please do what I have suggested above. Let me know how it goes.


Changing the Polygon network RPC may help you.
I did try it, and still getting the same error. I tried inserting different RPC links with no luck.

1 Like

Also when I try to swap tokens in data i see this message

1 Like

First, make sure that both your MetaMask wallet and browser are the latest version. Clear the browser cache as well. If it does not help, install the same wallet on another browser. If after doing all these suggestions the error persists, please contact the support team via the following link and report what you have done and the error you got.


This topic was automatically closed after 30 days. New replies are no longer allowed.