Fiat not showing only tokens showing

Now for a few months every time I open my MetaMask it’s shows the amount of tokens I have but not the fiat $$$ I have.

Now sometimes I close it reopen close it etc the fiat shows randomly. This happens every so often once I open close again loads of times. Then at a later time I open again and it shows again only tokens.

And these are coins that show fiat.

3 Likes

Hi!

Confirming you have the latest version of MetaMask downloaded?

Did these tokens ever show their fiat value consistently and accurately in the past?

3 Likes

Hi yes I always update MetaMask and this has been happening for months sadly.

Yes they have always showed fiat in the past.
It’s weird sometimes I open it and they all show but in general I have to open and closes it so many times.

4 Likes

Gotcha,

Would you mind trying these three steps?

  • Change the default fiat currency to USD or EUR in MetaMask Settings → General → Currency Conversion

  • Please also set Primary currency to Fiat in MetaMask Settings → General → Primary Currency

  • Then please try this, In MetaMask, go to Settings > Advanced and enable “Show Conversion on Test Networks”. Then MetaMask will start showing fiat values for networks other than Ethereum. I have read that sometimes it thinks all custom networks are “Test” network.

image

Let us know how it goes!

7 Likes

Hey thanks for the reply.

I have it setup on GBP
I have the fiat option (had it like that already)
Can’t find the advance option show conversion on test network.

I have an iPhone and latest MetaMask version.

Thanks for your help

3 Likes

Hi! Do you mind trying to set the default fiat currency to USD or EUR, just to test if it loads? You can switch back, just as a test.

4 Likes

Done and changed to USD and still nothing.

Just shows ETH on top only.

I have WLUNA and others. And they should all show fiat.

It started happening beginning of this year.

3 Likes

Thanks for trying all of this!

Can you try one more thing -

  • Please also set Primary currency to Fiat in MetaMask Settings → General → Primary Currency change to Native - what happens when you do this (anything?).

Thanks!

4 Likes

This seems to have worked.

Thanks a lot for your help.

This has been the fix I needed :grin:

4 Likes

Now I opened it again and it’s the same it doesn’t work :sob::sob:

1 Like

Oh no! I was so happy and then so sad!

Ok, can you please submit a help desk ticket? Let them know all the steps you’ve tried.

To file the ticket go to support.metamask.io, click the ‘start a conversation’ bubble. This will at first connect you to a bot but you will get connected to an agent. Share this post with them if it helps summarize.

2 Likes

Perfect thanks for your help

3 Likes

This topic was automatically closed after 30 days. New replies are no longer allowed.