Gas fees out of wack and no help support!

I transfered ETH for the first time and it went well. Gas fee was high (so I thought) but I was warned. Ok.
Tried a second transfer 3 days ago but the gass fee was as much as the ETH to be transfered!!! ($300 fee for $400 of tokens) So of course I manually lowered the fee it back to what seemed a “normal” amount, about $25 for the transfer instead of $300. It is still pending now for 3 days. Is that normal?
Also, when checking in Ethereum link, no dice. It shows “Sorry, We are unable to locate this TxnHash”. Tried another transfer only to now have that one pending. Great…
So I created a ticket with Metamask and got an automated message that was useless.
I have since requested support without any news back.
What do you guys suggest before I loose my shit.

@Jaxtrax , Welcome to the community!
Hi there,

Thank you for contacting MetaMask support.

The Ethereum network and gas fees can vary greatly. These transaction(s) could take a very long time depending on the network usage. You could wait for these pending transactions to complete or:

  1. You can attempt to speed up or cancel the Txs (if you haven’t already attempted this):

  2. You can also try enabling Custom Nonce in settings of MetaMask:

then send a new transaction. In the new transaction you can send TO yourself, meaning your MetaMask public address. Then in the nonce set it to the OLDEST pending transaction:

and set gas higher (to what is recommended on ETH amount can be left at 0.​

  1. If none of these options above work you may need to reset your account:
  • Click the account icon on the top-right corner of MetaMask
  • Select “Settings”
  • Select “Advanced”
  • Scroll down and click Reset Account
  1. If a transaction occurred FROM your MetaMask without your consent, it is likely you were hacked or you willingly gave your private key or seed to a site or person (which means you gave away access to your funds).

  2. If you did not receive funds from a 3rd party TO MetaMask, contact the 3rd party. You might also need to simply add the custom token to MetaMask:

Reply back if you still have questions or issues regarding this.

1 Like