Help with Pending Transaction

Hi. I have this problem too but it happened just this time, the transaction seems to be stuck since 3 hrs… I also tried to speed it up but nothing… what I have to do?

Hey @Mic, welcome to the MetaMask community! :fox_face:

You can either wait, speed up, or cancel this transaction. Here is more information on our Knowledge Base:


Thanks… I already did it and it was still on “submitted” state. Clicking on that and looking for the transaction hash in polygonscan, it appeared to be as 0 MATIC transaction and stated “Sorry, We are unable to locate this TxnHash”

Then I reinstalled Metamask and reactivated wallet by entering the secret phrase as Support Bot told me, and all transactions/swap list disappeared.

It still doesn’t show, not even in my polygonscan address page, the balance show up as before the swap

1 Like

Hi, you must put the address or transaction hash in the explorer of the network. If dont appear then perhaps the funds are in other network.

1 Like

In my address on ploygonscan ther’s no transaction, no hash…
We’re talking about a WETH/MATIC swap inside Polygon… How could they be on another network?

Anyway, since the balance was still the same, I’ve just tried again (3 days later) this time with Quickswap: it worked, and now I have Matic swapped from Weth.

What’s happened? Can a transaction go wrong and disappear? May I made some mistake I didn’t realize?

But another problem arised, this again on Metamask mobile app… On Metamask mobile app when I tried to send Matic to Binanace, it showed “submitted” but then no transaction were shown in the list, so no link to the hash page
I then tried again the same thing (second time) on Metamask brave extension: it worked.

Is there something wrong on the Mobile app ? (I have already reinstalled it 2 times) Anyone else with simimlar problems?

1 Like

Very strange. Well that must be a malware or a problem. I cant help you because i need investigate your problem.

I’ve also never being able to see the coin icons in Polygon Mainnet, although I use it since several months… they have all defaults anonymous icon…

This topic was automatically closed after 29 days. New replies are no longer allowed.