I purchased SHIBA with ETH but it does not appear in my wallet

I bought SHIBA last night. I see the transaction on Etherscan and I see it on coinstats via the API connector, but when I look in my MetaMask account. I don’t see my coins. Purchased on 1inch

You need to import the coins contact address under-> find custom token 0x95ad61b0a150d79219dcf64e1e6cc01f0b64c4ce

1 Like

Like Slimer said above. Shiba Inu Tokens will not appear on your wallet automatically you have to add the token to the list so that it will appear. They are there, don’t worry, they are just not being shown.

You have to push the “Add Token” button at the bottom of the token list. Choose Custom Token tab, and it will have a space to put the contract address. Copy the address on there and the rest of the info should fill in by itself. Push Next, then Add Token and you should have the Shiba Inu Token added. Once you back to the main list your Shiba Inu should be there in all their glory.

Hey guys I had the same issue with my HOKK token and when I add the token it appeared but the balance is showing zero. Any idead how to fix this issue

That sometimes happens and it’s nothing more than a visual bug. Go to etherscan and paste your address to the search bar. Next, you will see your ether balance and below that you will see your custom ERC20 tokens as well as their value in USD. If you can see that, then it just confirms what I said but if you don’t see that, that token might not be supported by etherscan or you might have experienced an error. Can you send me your wallet address (it’s the address that starts with 0x) so I can take a look?

1 Like

Yes everything is shown in etherscan but that still do not help my issue. If I want to transfer my token out of metamask it says I have zero balance so what do I do, leave it forever there??

It might be a visual bug but its still not letting me transfer my balance to another wallet

Try setting up metamask again in your mobile phone. If that doesn’t fix the problem, delete MM on PC and download it again. If none of these work, contact support

1 Like

Hi! I am trying to add shiba inu token but it seems the process is not finishing so I am not able to add it!!

I have tryed so many times following the comolete process, could you help¿?

Thanksss

Are you seeing any error messages?

Nop, it is just going back to the main screen but without shiba inu added

In this case, may I know what version of MetaMask are you using? Have you tried reinstalling?

I just downloaded today… 2.5.0

I reinstall and now it appeared… thankss

1 Like

First of all, there is something I want to ask. I made a swap from the QuickSwap platform and converted it to USDC coins, but I cannot see my USDC coins in my Metamask wallet. Moreover, although I see the process from both QuickSwap platform and Metamask Activity. What could be the reason for this? There is no problem with it in my Metamask wallet with USDC token attached. Thank you.
I can’t see my USDC coins at the moment and I am suffering.
I want the matter to be resolved as soon as possible. good work.

Hi @omeraksoy. Welcome to the MetaMask community.
If after a successful swap transaction, you’re not seeing the swapped token in your wallet, please add it as a custom token to your MetaMask’s token list to enable it to see and display them.