Issue with MM Chrome Extension not loading--only shows spinning circle

Help! Within the past 60 days, my MetaMask Chrome Extension stopped working properly. When I click on the MM extension icon, the popup window only shows spinning circle. (see image)
Issue is only occuring on chrome on my Windows 10 Pro PC x64. This issue does not occur when using Firefox MM extension on same PC. Issue does not occur when using chrome on my Macbook Pro.
I have already tried all of the following, and issue persists:

  1. Closing and relaunching the chrome browser application
  2. restarting my computer
  3. restarting my router and cable modem
  4. clearing chrome browser cache
  5. deleting all chrome browser cookies
  6. using a different chrome profile
  7. disabling all other chrome extensions
  8. uninstalling and reinstalling MetaMask chrome extension
  9. uninstalling and reinstalling chrome browser application

Hoping MetaMask Support will be able to help me resolve this issue.
Any suggestions/advice greatly appreciated. Thank you! :pray:

1 Like

Hi @Zenboy,

I had encountered a similar issue before and it got resolved after removing and installing the MetaMask extension again. Seems like you have tried this option as well and it has not worked. It would be best to contact the MetaMask support and report the issue. Before doing so make sure that you chrome browser is the latest version.

  • This will connect you to a bot at first, answer some questions and it will open a ticket for you with an agent.

Remember - NOBODY, including from support, will ask for your secret recovery phrase or for you to input it onto any website for confirmation.

4 Likes

MetaMask published a new update of their chrome extension today: Version 11.7.5
I updated my MM chrome extension to this new version, and issue went away!

5 Likes