Lost USDT from metamask to sollet using solana bridge

I tried sending/converting 10k usdt using my sollet wallet. I connected to my metamask and began the process. It was approved in my metamask and confirmed on both solscan and etherscan. The tokens never appeared.

A few things:

The USDT wallet (not soUSDT but wrapped USDT) in my sollet says “this is an auxiliary token account.” After the tokens didn’t appear I added another USDT wallet to my sollet. Now I have two USDT wallet. I tried sending 1 USDT to the same wallet and it worked. It’s odd that it worked only after I added the official(?) USDT wallet to my sollet.

I can not figure this out on my own but it seems to me that the key to this has something to do with the associated account and/or auxiliary account. Please see screen shots below as well as the link to solscan transaction.

I am desperate here as I’ve lost a lot of money and cannot figure this out after over a week of trying. Thank you in advance!!

4 Likes

Can you provide your wallet address or approved hash, and I would like to know which cross-chain bridge are you using? There are some cross-chain bridges that are not native tokens after they arrive in the account, but a packaged token name

6 Likes

Hello @malatang.atf and welcome to MetaMask community.
As @xf0707 mentioned, please provide the transaction ID and we will take a look at it.

PS: NEVER share the private key and secret recovery phrase under any condition, and never click on unknown links.

4 Likes

@Maryam1 @xf0707
I have been trying to post the approved hash here but it says I’m not allowed to post any links here neither can i send either of you a Pm. Kindly resolve, i am getting desperate, it’s alot of money for me :cry:

1 Like

By copy-pasting your hash,

1 Like

233W2fF52gDdEx2uuLQSvrN7JmWjaoCxmdKCxzmz6xw8swFYU5Jt9D4LWpL99Yrj4xw7n3EwHoeTArBy2cgkfxPF

2 Likes

Hello @malatang.atf and welcome to MetaMask community.

From what i can see, your bridge transaction was successful on both ends, the funds left from your Sollet wallet and arrived in your MetaMask wallet on Ethereum network successfully. The contract address of the USDT which you sent and received were the correct USDT ones on both ends.



This is what i saw on blockchain. Your USDT should have been in your MetaMask wallet shortly after you bridged the funds, as indicated above.
Try to check if this article might help you to see your funds properly, although after such a long time, this might not be the issue if you still think you can’t find your funds.

3 Likes

Thank you for your response. The transaction hash you have provided is for the Solana network. You have possibly used a cross chain bridge protocol such as wormhole. Then, please provide your MetaMask wallet address and the network to which you have sent your USDT. For example, have you sent USDT from Solana to Polygon network? Please mention the destination network as well.

In case of using the Wormhole bridge to transfer your USDT to MetaMask, you will receive wormhole USDT tokens and you need to change them to USDT using a Defi. That “might” be the reason you can not see them in your MetaMask wallet. If you provide your MetaMask wallet address and the destination network, we will take a look at it.

Again: NEVER share the private key and secret recovery phrase under any condition

5 Likes

Thank you @Chinzilla. I have just seen your response.

5 Likes

This topic was automatically closed after 30 days. New replies are no longer allowed.