Lost WETH due to insufficent funds to cover gas fee

This is the second time i lost funds (WETH) on Metamask

today i tried unwraping 0.019 WETH to ETH from my metamask wallet using polygon bridge, and when it said i don’t have enough funds to cover gas fees (75 euros gas fee for 60euros crypto? are you kidding me?) i wasn’t able to complete the transaction, but my funds were already gone by then

and similar situation happend about a month ago when i tried sending 0.021 WETH to binance, my funds never arrived to binance even though transaction was “completed” and of course funds were gone from my metamask wallet, and i tried contacting support from both binance and metamask, but to no avail

can anyone on this support or community help, or at least tell me that my funds are gone forever, so i can forget about it and move on already

Have you tried reaching metamask support for assist

i did, i just got automated e-mail replies for now

So have they resolved your issue

no, they still did not