Matic Funds Missing from Metamask after transfer to Matic Mainnet

Dear Community,
I need help,

And I am willing to offer a small token of appreciation :slight_smile:
I would appreciate any insights, and anyone helping me to recover my coins I will gladly share with them 100 of my Matics.

12 days ago, I sent Matic coins from Metamask Wallet to my new Matic Mainnet Account.
The transaction is still pending… here is what I tried:

  1. I attempted to speedup & cancel repeatedly (lost over $150) nothing happened.
  2. I tried sending 0 Eth to myself, with same nonce… didn’t work… last transaction is also pending
  3. I reset my account, and I didn’t save my log :frowning_face: and that didn’t work
  4. I reset my account again, checked my matic mainnet account, nothing
  5. Please note, I only have two assets listed in the wallet Eth & Matic, and there was a pending ETH transaction from 4 months ago, but I did a number of successful transactions after that, no issue.
  6. I have TWO Transaction hashs:
  7. Pending on desktop (I didn’t back that up, unfortunately)
  8. Successful transaction: (how come successful and I didn’t receive my coins)??

My Public address:

I can’t attach any screenshot and I do have a log that I saved after the second account reset.

Help please

so first of all Im new with the Matic network but i hope i can help.
DONT send tokens from Metamask wallet (ethereum network) to Matic (matic mainnet) , that was the mistake if you wanna do that you have to go to Matic wallet and there is an option that is says: MOVE FUNDS TO MATIC MAINNET, so that you can transfer funds using a bridge between both networks.

your problem is a little confusing and it will required more details to have a better answer,
Im assuming you added the MAtic mainet to your Metamask wallet right this way:

How to Use DeFi on Matic Network with MetaMask?

how did you send your Matic token on metamask to the Matic Mainnet Account.?
is the Matic Mainnet Account you talked about IN your Metamask or is the one provided on the website (
just checking the etherscan transaction you did you sent the tokens
FROM : 0x3F333A3A51550D8eF4B89AF7568c541dCbC30bA0
TO : 0x3E58842eE58C5712f2dB1073c042ee7Af9EF2033
wallet FROM has $23.50 (@ $1,941.40/ETH)
based on what you stated that you only have eth and matic then it should be there since the value kind match the amount of tokens you sent.

however, address TO has $138.95 (@ $2,002.16/ETH) this address can your tokens too.
its hard to get a conclusion if there is not more details, but CHECK if you recognize the TO address, maybe its another address you have on your metamask.

let me know if that works

HI Julio,
Thank you for extending your help, much needed, much appreciated.

in my wallet now it is only abt $25 Eth.
the To address I don’t recognize,… I don’t have $138 anywhere else. That’s what I am trying to figure out… when I sent the Matic I actually got the address from Matic Wallet (receive) which was same as my Metamask address, so ideally the funds should come back to my wallet eitherway.

Two questions maybe you can help me Julio:

  1. The missing Matic are 1976 tokens, so their corresponding value is abt $2000+ so the To address does have my coins? how can I know who is that? or where it?

  2. The same successful transaction was showing as “Pending” still actually… but I reset my account. (here is a the last log attached after my 3rd or 4rth account reset) you may find something there.

  3. Couple of attachments to show the pending :slightly_frowning_face:
    Again Julio, thank you so very much, I hope we bring these babies home


(Attachment MetaMask State Logs (1).json is missing)

Julio here is a link to the last and only log that I saved, I hope we have some useful info.


Ok, i think I might have 2 possible solutions.

I checked your wallet and you have 26.36 ether and almost 2k. if you only have 2 tokens in THAT wallet , that 2k must be your Matics.
Let’s try 2 things:

Possible solution 1:

As you noticed your metamask wallet (0x3F333A3A51550D8eF4B89AF7568c541dCbC30bA0) has the same address than your matic wallet website ----BUT — they are in two different mainnets. Let me explain it with an easy example,
Let’s say your address (0x3F333A3A51550D8eF4B89AF7568c541dCbC30bA0) is a house with TWO bedrooms (master bedroom
and another bedroom) and by DEFAULT your tokens are in the Master bedroom ( ethereum mainnet) BUT you sent it to your other bedroom (matic mainnet). When you open your metamask you don’t see your tokens because by default it display your master bedroom and what is in there but not what you have in the other bedroom ( matic mainnet). You need to look for your tokens in THAT bedroom.

So what you need to do it’s SET UP MATIC network on your Metamask, and check if your tokens are there ( you need to switch from ethereum mainet to matic mainet ) . In my previous message I ATTACHED a link that shows you how to do that.


IF that doesn’t work, try to readd the Matic token on metamask ethereum mainnet
If you see the matic token with 0 BALANCE,
Go to ADD TOKEN, then CUSTOM TOKEN, in this part you will need to add the TOKEN ADDRESS, TOKEN SYMBOL, and DECIMALS OF PRECISION.
you can find the info here in the Matic contact address on etherscan:

Try those solutions, hopefully one of then will work.
Still have some doubts about if the first solution works that means your tokens were transfered to the Matic mainnet but, how can I see your tokens value on the ethereum mainnet using etherscan? it shouldn’t be there, it should be on the matic mainnet explorer (like the ethereum scan but for the matic) .

The second solutions makes more sense but why does your Metamask not recognize the token if they were there before the transfer, if you received back it should display it, unless there is some kinda glitch on the metamask, that’s why I suggested to reADD the token so it can be recognized in your metamask.

Hope it works, let me know.
Pd: I will attached some pic of you wallet and metamask


In my first post I mentioned that when you transfer your funds from metamask to your matic wallet website you have to use BRIDGE to donthe transfer, in this case you pretty much sent it directly to the wallet and probably metamask tried to do the Same thing using a bridge that will explain why on your etherscan there are 2 transaction from your wallet to another wallet exchange and so on, but it didn’t finalize the process.
When I did this before on the matic wallet I paid like 2 or 3 times I guess when you send the token to the exchange, then the exchange swap the token then send it in the other mainet.
So this makes more sense and apparently the funds would be stuck on the exchange wallet and you haven’t recieved becuase you don’t have enough ether for gas in your metamask.
Try to add at least 100 dollars in your metamaks wallet.
Ether fees have been really high like 100 ish dollars lately just for 1 transaction so you probably run out of eth for the final transactions where you get your tokens back.

In the pic where It show your wallet, you can see the 2k dollars in tokens, but you can’t see it.
Normally when the tokens exist in a wallet you can see then regardless if they display on your metamask or not.

1 Like


First thank you for taking the time to help me out :pray:

Here is what I did:

  1. I did add the custom token as in the picture I hope I am getting this right: the address is the etherscan which is labeled as (Contract)… right?

  2. I did add Matic Mainnet to Metamask (and I see a balance of 0.001) this was weird

  3. I added the customer token as you suggested twice once in Metamask ethereum mainnet and once in Matic Mainnet. nothing changed.

  4. By the way, since it was pending I have added a $90 twice… and it was almost consumed in ether gas trying different things… besides when I first sent the Matic the eth gas fees estimated was less than $20. Should I top up another $100 again?
    Can I refresh? I tried to remove Matic and add the customer token couple of times, nothing changed.

    Please see the attachments and let me know if you see me doing something wrong there…


It seems you did try the first 2 solutions ( adding matic mainet to your wallet and RE adding the token),

  1. Yes, the contract address
  2. That is a welcome balance matic gives for using the matic mainnet, and that can be use for transaction fees which are almost 0.

in this case try the last solution I mentioned,
Add more eth on your Metamask and check if it requires another approval for fees since the process hasn’t finished.
As I said before, in a regular transfer of matic from ether mainnet to matic mainnet its not fast it takes some time to actually have it on your matic wallet and you have to pay 2 or 3 different fees, they use a BRIGDE for this while process.
Remember, ethereum fees were really high and were delayed ( some times hours) in several transactions lately, so maybe at the moment second transactions kicked in the fees were too high and you accepted without knowing you were paying 100ish for that transaction.

I have some pics where IT shows your tokens were transfered to a new address
FROM : 0x3F333A3A51550D8eF4B89AF7568c541dCbC30bA0
TO : 0x3E58842eE58C5712f2dB1073c042ee7Af9EF2033

( I think this is the exchange/bridge that metamask used to send your tokens ) in your first transaction. However, the second transaction is really tricky to understand
what happend (not sure how exchange or bridge works) but this new address did 2 more transactions, and in the last transaction

It recieved the matic tokens back in the same address they were sent in the first transaction
TO : 0x3E58842eE58C5712f2dB1073c042ee7Af9EF2033

And the tokens are there… Im guessing the final process is missing where this TO address send you the tokens back to your wallet that’s why I was suggesting to add more ethereum in your metamask so it can be use in the next transaction.
In the picture were you show the ACTIVITY LOG , you wrote you cant speed up or cancel the transaction and that is because you only have 9.59 dollars and fees are way higher than that for sure, check here to see the price of gas, and i think your funds are in uniswap and current price of gas is 30 ish, this will change constatly during the day but as a reference right now.

for the future, any time you are planing to use metamask to send or swap check the price of gas so you will have a better idea of how much you will pay , there are some times during the day were prices are really low (3 or 5 dollars) just chek the price of gas.

to wrap up, first check price of gas on the link i added and if its less of the balance you have on metamask (or add more ethereum in your wallet) and try to speed up or cancel the speed up.

this transaction has been pending for so long hopelly this can work.

I will add more eth by end of day.

By the way, when I tried to send the tokens to Matic mainnet, the Receive address was my own Metamask… so you are right… I sent it to myself, that part I think is now clear.

I will add a $100 eth and wait.
By the way, I did try to send 0 eth to myself and that is also pending.

Will update you soon,


sounds good, let me know if it worked

If you buy matic from a CEX or you buy it on UNI it will be ERC20 you can send it to meta mask using Ethereum main net the standard setting park it there for the moment and follow the next steps.
Go to quick swap exchange there you will see in the top right a heading that reads Bridge Assets
click on that and matic web wallet a new tab will open up
Again in the right hand corner you will see move funds to matic main net.
click that and it will open another tab this will be the bridge from Ethereum net work to
matic network after agreeing to matic access to metamask you will be able to see tokens in your metamask ETH will come up first remember gas fees in ETH follow the prompts from there
you can do most of what I said with out entering any tokens to get the feel of it then move a small amount say 20 Matic from meta mask the fees will hurt but its worth it it takes about 7 to 10 minutes to cross the bridge and eventually oncve over the bridge the tokens will show up in the matic wallet as well as the metamask I suggest you bookmark the exchange and once the wallet pops up on a tab book mark it as well I suggest you go to quickswap exchange via coingecko so you get the real thing type in quickswap into the search bar you will see crypto currency at the top and exchange underneath go from there. Best of luck if you need more assistance put a post on Carbon social media platform and some one will pick it up I will if you reply to one of my posts look for Bitdaddy and if your still struggling we will go from there. cheers

I have opened the quick exchange Swap now, connected my metamask, opened the bridge and for now I have only sent $23 ETH with abt $10 fees… to test the bridge, been 19 minutes… network congested now.

If this does not work, I will buy few Matic as you suggested maybe 20+ (I can’t find mine anywhere) and then try to bridge that as well.

Will reach out via Carbon social media platform you mentioned.
Thank you so much Tezza.


Hey @zoro26,

I hope you have managed to help @jamjom with his problem here.

I actually have had something similar happen to me today, if you could help me I would greatly appreciate it.

At about 9am this morning (15 hours ago) I transferred 5,4 Eth to the Matic mainnet. I did this by going onto the Matic Bridge v2 page and then synced with my Metamask wallet. It picked up that I had Eth in my wallet and i clicked on transfer Eth to Matic Network. The transaction proceeded to go through but was hanging for a very very long time. After an hour I realised this transaction had failed. I looked on Etherscan and it showed that it had dropped.

I though that the funds would then be returned to my metamask wallet but they have not appeared.

Please see screenshots below from Etherscan as well as my Metamask wallet. Your help would be greatly appreciated.

My Metamask public address is:

Transaction ID on Metamask:

Transaction Hash on Etherscan:

Transaction sent to:
Contract 0xa0c68c638235ee32657e8f720a23cec1bfc77c77 (Polygon (Matic): Bridge)

Your help would be greatly appreciated.

1 Like

Hi guys sorry to jump on this I am looking for some help too if thats possible ok here we go
I transferred about 120 quids worth of matic from my metamask direct to quickswalp as I wanted to get some ploydoge within metamask I went to browser and then quickswalp and there is nothing there any help on this is gratefully appreciated also lost some ETC but maybe help on that can come after I suss this out
Many thanks, I am new so not sure what to check or how to do anything really

Hi Julio,

Let me update you with what I have done:

  1. I have sent some Eth abt $20 from Metamask to Matic Bridge, and I can see it there… that does not show in the Matic wallet, only in the bridge. But the transaction was successful.
  2. I have topped up my Metamask w a $100 as you suggested, but now since I reset my account, I can’t really see any past transaction whether pending or successful.
  3. It has been over 12 hours almost since I topped up my Metamask, and I checked Matic wallet & bridge and Matic coins are nowhere still.
    I feel we are close to finding something!
    Btw, about your last question on the second address Matic was sent to, that was supposed to be the Matic Wallet.

Any idea?

Thanks J,


Hey Bro,

  1. I’m assuming you use the website bridge to do this
    If it went through, you just probably have to type it there to find it in your matic website wallet.

  2. Damn, I thought you still have access to the pending transactions, I guess we will have do something different there. Did you try to look for the matic token in THE BRIDGE matic net (first pic)?

your tokens are stuck in the unisawp wallet.

I just checked your wallet address and it seems that your 2k token value you had ( I though it was your matic token) are not there anymore, I guess you solved the issue. Right?