Issue with MATIC transactions

I wanted to buy a token that I need matic to buy, and it is only available on quickswap. I go to quickswap and it says “connect to matic” on the top right page. So i click and it creates a “matic wallet”. So i go to my binance account and get some matic. i then transfer the matic to the “Matic Network” Except when i do this, it goes into my “Ethereum Mainnet” network instead. Now when i go back to quickswap, it does not let me use the Matic i have because it wants to connect to the Matic Network Wallet. But my Matic is in the Ethereum Wallet. How can I move the matic from the ethereum wallet into the matic wallet on my metamask?

Hey @Ech0, you’ll need to move the MATIC to the Matic/Polygon network using the Matic bridge. You can find the bridge for that here: Matic Web Wallet v2

wow. can you help me. So it said my gas fee was 5 dollars or so in ethereum. and i only had about 6 dollars or so. so it took my gas fee and started the transfer. Now i just checked my wallet and my Matic is STILL in my ethereum wallet? I searched the transaction on etherscan and it says it was successful. So what is the problem? i will give you the address to my matic wallet. Hopefully you can figure out a solution for this.

My metamask wallet address: 0x1Fa4137388C07684B972a00218F5317A8713D938

Hmmm… according to Etherscan, you successfully submitted a transaction to move 0 MATIC tokens… I think you had forgotten to enter the amount of MATIC tokens you wanted to move when you used the bridge.

no i pressed MAX…it processed one time for like 5 dollars, then asked for a 2nd process fee and i did not have enough ethereum to cover it. so i left the page open until i could deposit ethereum into metamask to pay for the transaction. well i accidentally exited the page and when i went back to the matic exchange site you gave me the transaction process was gone

when i go to my matic wallet the matic symbol has a yellow excelemation mark and says we cannot locate your tokens or something

Polygon’s (previously called Matic) infrastructure provider is suffering outages currently under the load from all the growth. That error you’re seeing should resolve itself soon as new infrastructure is rolled out. Alternatively, you could run your Polygon node and not be dependent on the third-party provider.

Now i just sent 0.02 etherum to the metamask ethereum mainnet address link that is on my account, and the money disappeared! what is going on with your app! the ethereum was taken out of my binance account. It’s been two hours and still nothing!

I went on the binance.us site. I picked withdrawal. I entered that minimum amount needed 0.02. I put my metamask ethernet address in the recipient page. I paid the transaction fee. where the hell is it?

What you’re describing are not issues with our app.

Unfortunately, Binance defaults to sending your funds on Binance Smart Chain (even ETH) instead of the Ethereum Mainnet. Many users don’t realize this is happening when they withdraw from that exchange, and they end up forced to buy BNB tokens from Binance which are required to pay for gas on Binance Smart Chain. You can read about this here:

https://metamask.zendesk.com/hc/en-us/articles/360049675331-How-to-see-your-missing-tokens-after-withdrawing-from-Binance-BSC-

so is this money gone? lol this shit is so confusing.

I need ethereum on my metamask app to be able to withdrawal the matic. because gas prices are paid with ethereum. So i tried to transfer ethereum to my etereum address from my binance address. But youre saying binance decided to change my funds to BNB? ive sent ethereum to my metamask wallet before and i did not incurr this problem.

So is the transaction going to go through? am i beat for the money? should i try again? how can i get ethereum into my ethereum wallet on metamask from binance without this happening???

I just checked both the Ethereum blockchain and Binance Smart Chain (the other blockchain I thought your money would be on) for an incoming transaction of .02 Ether at the account address that you provided. I see no incoming transaction from Binance.

Take a look here:

Are you sure that is the right address? At this point, you probably need to contact Binance. Unless you sent to a different MetaMask address, those funds never hit your MetaMask account.

Look at the message I got from binance.

When you open the metamask extension on chrome, then go to the “ethernet Mainnet” wallet, and I copied that address. I then went to binance.us and put in the address to send 0.02 Ethereum. Look at this confirmation email i got from binance.us. It is in the attachment on this reply.

I clicked the verification a while ago…

what should i do? binance takes forever to respond. How can i successfully transfer Ethereum to my metamask extension network? all i did was copy and paste like i always do. I’m afraid if i try and send more ethereum that more of it will disappear also. I still only have 1 dollar in ethereum on my metamask.

my issue is i have a “pending transaction” i tried to S E N D from my Metamask and it screwed something up… i cannot do ANYTHING with…i also
screwed up and put waaay too low of a gas fee somehow and now i cannot cancel or speed up the transaction, not sure what to do at this point, PLEASE HELP!

So im not sure what i should do.

Do i need to use something other than binance?

How can i get the money thats in my binance account, into my metamask ethereum account

I’m sorry Ech0, but this issue you’re having is completely on Binance’s side. I’m not sure how I can help.

@Shaun please create a thread for your issue.