Metamask and Etherscan issues

Im in need of some major help. Yesterday (5/15) I had a pending transaction on Metamask that had been there for 6 days and was trying to move ETH from Curve.Fi to my Metamask wallet. I created a transaction but nothing happened after several hours so I found out I needed to push that pending transaction through. I did that and re-tried the Curve transaction and nothing happened again. In the mean time I tried to move some Eth to Matic. It is showing 2 transaction in progress on Matic but nothing on Metamask. I reset my Metamask account several time and several pending transactions went away so i thought I could try the Curve.Fi transfer again. Nothing is showing up in Metamask but I now have a pending transaction on Etherscan for this and I still have the 2 transactions processing on Matic. Bottom line is I think I screwed up Royally and I dont’ know how to get back to square one. Any help would be greatly appreciated. Thanks


After resetting my Metamask account an waiting for 10 hours my ETH was processed out of stETH and back to ETH on my Metamask wallet. I still have 2 Transactions in Progress on the Matic Network and cannot seem to find out how to cancel those. I don’t want to try another transaction to move ETH to Matic until these are gone as I am afraid it will just keep add problems and issues to my current situation. Does anyone know how to cancel a transaction on Matic??? Thanks

Welcome to the MetaMask Community @Wyokid!! :fox_face: :rocket:

Please try the steps here to cancel your transactions.