Metamask gets blocked thinking

Since last update, the app for chrome version 10.25.0 gets blocked thinking when pressing the send button. It is impossible to send tokens.
same issue in two computers with same version.

1 Like

Changing the IP via VPN, changing the VPN and/or changing the RPC may resolve the issue. Please do it and let us know how it goes.



In addition to what Maryam has shared, please make sure you have the latest version of Chrome installed too.

Be sure you have your Secret Recovery Phrase written down somewhere safe.



Hello, same issue here. Problems sending tokens, but also problems with the fees shown making swaps (sometimes it shows a very low fee, sometimes it doesn’t update and you have to cancel and try again and again… Sometimes it gets stuck when you cancel a swap, or when you accept it, and keeps “thinking”, although the swap has been sent to the blockchain…)

Please take a look, it is really hard to work this way (the previous version was smooth).

For your info, I have the latest version of Chrome and have tried with different RPCs.

1 Like

nothing works. all tested. is the updated chrome app. in android mobile, the app works fine

also checked. latest one

in addition
I make a swap, and the popup window for confirmation of gas (much worst than earlier one) keep thinking EVEN THE SWAP HAS BEEN LAUNCHED. Mandatory to close the blocked window through the X corner.
The window for gas fees is now a mess. also gets blocked.

How can I go back to the previous version of the Chrome extension???

1 Like

It would be best if you contact Support team at and click Start a Conversation


Once you click Start a conversation a live chat bot will appear on your screen. It will give you an automated response at first, but afterwards you should be able to contact the support team directly.

1 Like

I know. My last problem was not solved by him, and told me to write an email. and to write here in the community.

uninstalled wallet from chrome
re installed
changed IP

by the moment the only problem is that after a SWAP or SEND confirmation, the popup windows doesn’t close and keeps open, with the roulette turning. Even the swap or send has been done.

any sollution?

Can you share screenshots of what you see? Maybe we can understand better where the issue might be with pictures.


this permanently

until I press this

1 Like

Have you tried changing browsers to see if the issues is related to MetaMask or to the browser and its load?


I have two computers, both with windows 10 and chrome. Problem happens in both.
Also tokens are not stable, sometimes dissapear.
Also sending is a mesh, gets blocked. Many F5 and finally in one of the two computers, I can send.
This version is a mesh!! Yesterday was going perfectly, until I received the update.

1 Like

justo for your info, it seems that in mozilla works fine. some problems happen with chrome. You should correct them

hi. just want to answer your this question.

How can I go back to the previous version of the Chrome extension???

Usually the new version is more complete than the old version, and we generally recommend users to use the latest version.

If you really want to go back to the old version, please make sure you have backed up the seed phrase and private key beforehand. Follow the steps below to find the old versions.

  1. Find GitHub under the official website
  2. Click Release on the right, you can find the historical versions.

I have exact same problem about 3 days ago when MetaMask auto-updates, that i can’t control or downgrade. MetaMask window freezes after any action. Latest Brave on Linux. No upgrade since January. Has been using MetaMask for years with no problems. Please pay attention to this issue. Thanks.

@user463 would you please contact our support with this so they can gather details? Visit and choose the “Start a Conversation” button. Answer a few questions from the chatbot to be connected to live support. We will never ask you to provide or verify your Secret Recovery Phrase.

This topic was automatically closed after 30 days. New replies are no longer allowed.