Metamask Mobile Issues (Android)

So this issue popped up a couple weeks ago. (see picture below)

“This website has been blocked from automatically opening an external application”

Within my MM mobile browser, it doesn’t happen on all sites but some notable ones are uniswap,
mute (sksync)

There is also another issue of confirming transactions, for example, usually when I hit “swap” or “approve” on a dapp usually you get a pop up to confirm the transaction showing the gas. This sometimes doesn’t happen “getting the pop up”

I can however access these sites SOMETIMES through my mobile chrome browser (not wallet browser) and using wallet connect. But still confirming transactions and approvals is spotty.
One last thing to add, for example access uniswap. If I access uniswap from the search function within the wallet browser (typing uniswap into the search bar and accessing site) If I clock on “launch app” from uniswap home page it will open the app within my chrome broswer on my phone?

Sorry I hope this isn’t too convoluted, I cant seem to find anything about this anywhere.

I am running most up to date software on my phone (Google pixel 6 pro)

MetaMask is up to date, chrome is up to to date, cleared cache, etc, etc.

Is this a known issue?

I’m very close to just switching wallets all together.


@Juicebox10 ,

Thanks for reporting! We have seen very little reports of this. If you would, please reach out to our support so they can gather more information. For support, visit: > choose the Start a Conversation button > answer a few chatbot questions, you will get connected to live support.


@Juicebox10 do you happen to be running GrapheneOS, or a high-security/high-privacy Android OS or have you configured your Android operating system any differently than a default install?

Pardon the mysterious question instead of a useful response - let me try again.

I think this error is due to Android App Permissions. This is a solution that worked for me:

on the client phone:
Settings > Apps > Default Apps > Opening Links > MetaMask > Add Link > Check “” > Add

I am on GrapheneOS which is a hardened Android-based OS, I have yet to verify whether I can reproduce this issue on a “normie” Android phone; my hunch (because it seems like no one on the whole internet other than you (@Juicebox10 ) and I have experienced this issue) is that vanilla Android lets MetaMask control the Opening Links setting upon install.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.