No confirmation pop-up on Mobile Wallet


I am trying to use Uniswap with my phone, however it is requesting that I confirm the transaction with my Metamask wallet.

On my desktop it will simply grab a pop up of Metamask and give me that option.

However the mobile version doesn’t seem to do that.
It loads the App, but then there is no option to Reject/Approve the transaction.

Apologies if this is in the wrong thread!

Any help with this would be much appreciated!

Welcome to the MetaMask Community @Greatbananaking!! :fox_face: :rocket:

Are you using the in-app web browser? If not, please try doing so.

If you are and still are not receiving the pop up, please provide the device you’re using, version of OS, & version of the MetaMask app.


Thank you for your response!

I had asked that question and then I tried it one more time. I ended up trying it once more, got busy, and then it worked. Since then I have given it more time and it has yet to fail again. It seems that, while I waited the same length of time as with the Firefox Browser, I was not waiting long enough for the mobile app!

I should also say that I’ve never had a problem with the Firefox extension either.

Thanks for an awesome wallet!

So glad to hear it worked and that you’re enjoying MetaMask!