Metamask Smart gas estimate - issues and how to turn it off

Hi, few days ago after loging into MetaMask I got a pop-up window about some “Smart Gas Estimate” feature in MetaMask. I was asked whether I want to turn it on. It was supposed to give me better gas estimates, save gas and so on.

Now I’m randomly getting following error:
“Cannot estimate gas; transaction may fail or may require manual gas limit - UNPREDICTABLE_GAS_LIMIT”

How do I turn that smart gas estimates off? I cannot find it anywhere in the MM settings…

3 Likes

This intelligent estimation cannot be turned off. It is a real-time estimation of the gas required for your current transaction. Only in this way can you avoid losing a lot of gas in some extreme cases. Of course, if there is such an inestimable problem you mentioned, you can stay on the transaction page for a few seconds, because sometimes there will be some delays in the data display. If the problem is still not solved, This may be related to the settings of your custom network. You can delete the current custom network and add it again. At the same time, you can enable advanced gas enhancements.

3 Likes

Hello @tomnf7
If you mean the “Advanced gas controls” feature, it can be turned off as follows. Please see the image.
Settings —> Advanced —> Advanced gas controls

2 Likes

This topic was automatically closed after 30 days. New replies are no longer allowed.