Metamask stopped working as of today, 2022-08-04

As of today, I cannot connect to MetaMask any more from our site.

The chrome plugin gives the error (on any page):

TypeError: Cannot assign to read only property 'chainId' of object '#<l>'

And when trying to connect, it gives the error

TypeError: Cannot assign to read only property 'selectedAddress' of object '#<l>'

This started happen today, without any update on our part (and as stated, the errors appear on all pages, so seems to originate from the plugin itself).

I am using the Brave browser on Win 10.

I guess I just wanted to report this, but don’t know where.

Thanks,

1 Like

Hi already reported the same issue (form post #22388) . And also chatted with the support, who alerted the developers about it. So lets hop it gets fixed soon.

By the way the problem seems to be Brave+MM related … in Chrome it worked for me.

2 Likes

hi @Mauser

Thanks for your reply, and good to know it’s reported.

cheers!

1 Like

Hey @T_repseJ, welcome to the MetaMask community! :fox_face:

If you would also like to report this to the support team so they can collect more information, you can contact them at https://metamask.zendesk.com/hc/en-us and click Start a conversation

Thank you!

2 Likes

also got the error on a normal app which don’t have meta mask

Hello and welcome to the MetaMask community,
Please refer to the link above shared by @nakedwinnie and report the issue to the support team.

1 Like

Hello @T_repseJ

Can you try to go Brave Settings → Wallet and set your Default crypto wallet to NONE and let us know if it worked.

I just had the same issue and I managed to fix it, found the solution on github (I will post a screenshot since I cannot post the link).

3 Likes

Solution and issue tracking provided here :slight_smile:

[Bug]: BRAVE browser - Cannot assign to read only property 'chainId' of object · Issue #15460 · MetaMask/metamask-extension · GitHub.

3 Likes