BSC and Polygon not working in Latest MM Version in Brave

Hi it seems that in the latest Version (10.18.0) of the MetaMask Plugin throws errors when connecting to web3 websites with BSC or Polygon Network connected. (Is seems also be the case for Eth Test Networks) But it works if you have the Etherum Network selected.

I could reproduce this with the Brave Browser on Win10 and on a MacBook. (On both did it work some hours ago, with an old version of the Plugin). I tried to reproduce the bug on Chrome (set up a new wallet there) but it seems to work there.

Examples:
The Detail NFT Page on tofunft (collection: 0x85F0e02cb992aa1F9F47112F815F519EF1A59E2D item: 10004812036) throws the same error as our polychainmonsters page. (seems I can’t post links here)

The error is thrown within the InPage.js of the MetaMask Plugin.

Thanks for taking care of this asap!
Alexander

Find parts of the errors thrown in the console below:

=====================================
Uncaught (in promise) TypeError: Cannot assign to read only property ‘selectedAddress’ of object ‘#’
at l._handleAccountsChanged (inpage.js:1:39788)
at r (inpage.js:1:38276)
at o._handle (inpage.js:17:2422)
_handleAccountsChanged @ inpage.js:1
r @ inpage.js:1
_handle @ inpage.js:17
await in _handle (async)
handle @ inpage.js:17
_rpcRequest @ inpage.js:1
(anonymous) @ inpage.js:1
send @ inpage.js:1
(anonymous) @ injected-connector.esm.js:459
_catch @ injected-connector.esm.js:134
isAuthorized @ injected-connector.esm.js:458
(anonymous) @ web3hooks.js:50
invokePassiveEffectCreate @ react-dom.development.js:23487
callCallback @ react-dom.development.js:3945
invokeGuardedCallbackDev @ react-dom.development.js:3994
invokeGuardedCallback @ react-dom.development.js:4056
flushPassiveEffectsImpl @ react-dom.development.js:23574
unstable_runWithPriority @ scheduler.development.js:468
runWithPriority$1 @ react-dom.development.js:11276
flushPassiveEffects @ react-dom.development.js:23447
(anonymous) @ react-dom.development.js:23324
workLoop @ scheduler.development.js:417
flushWork @ scheduler.development.js:390
performWorkUntilDeadline @ scheduler.development.js:157
9inpage.js:1 Uncaught TypeError: Cannot assign to read only property ‘chainId’ of object ‘#’
at l._handleChainChanged (inpage.js:1:39117)
at l._handleChainChanged (inpage.js:1:46662)
at l._handleChainChanged (inpage.js:1:44260)
at s. (inpage.js:1:45866)
at i (inpage.js:1:56067)
at s.emit (inpage.js:1:56607)
at inpage.js:1:55131
at d.write [as _write] (inpage.js:1:55154)
at w (inpage.js:17:29867)
at inpage.js:17:33045

1 Like

Hey @Mauser, welcome to the MetaMask community! :fox_face:

Seems like this has been an issue with a couple of other users with the latest version.

Can you submit a ticket to the support team so they can collect more information? You can do so at https://metamask.zendesk.com/hc/en-us and click Start a conversation

Thank you!

6 Likes

Solution and issue tracking provided here :slight_smile:

[Bug]: BRAVE browser - Cannot assign to read only property 'chainId' of object · Issue #15460 · MetaMask/metamask-extension · GitHub.

3 Likes