Metamask stuck, i have reset it so i cannot retrieve the transaction ID

I need help in solving my MetaMask, it got stuck and during the process, I was asked to clear my transaction history. Now, I need the transaction ID to make a report and solve my problem… but I can not retrieve it and my MetaMask is still stuck. Whenever I tried to do anything, it will show errors or failed transaction. Please someone help

2 Likes

Hey @realazeezali, welcome to the MetaMask community! :fox_face:

Are you looking for a failed or pending transaction? If it was a failed transaction, then you should be able to find the transaction ID on Etherscan with your wallet address.

Here is more information on our Knowledge Base if it is a pending transaction:

1 Like

No, its not a pending transaction that caused the problem it was an error that happens before the pending transaction starts to happen. is there a way I can retrieve my metamask history after resseting it? please help

1 Like

I have a similar issue. I transfered AVAX on the Avalanche Network. I have additional AVAX in wallet which is what the originaltransfer required. The speed up and cancel instructs me to add Etherium to speed up or cancel. I have ETH and WETH on the Ethereum Network. I have tried to transfer to Avalanche network but all I have done is waste Ethereum transferring it to myself in the Ethereum Network. Can anyone assist with this or instructions on how to fix this issue

3 Likes

Hey @Fatman7, welcome to the MetaMask community! :fox_face:

Please create a new topic for your separate issue :slight_smile:

2 Likes

@realazeezali, can you clarify what error happened before you tried the transaction?

You can also see your transaction history through Etherscan or another block explorer, depending on which network you were on, with your wallet address. Would you also be able to send your wallet address here? That would provide more helpful information.

2 Likes