Missing BNB after restoring Metamask wallet

I had a Metamask with some ETH on the Mainnet and BNB coins on the Binance Smart Chain. There were error on the ETH Mainnet not allowing me to send or receive my ETH. The Binance Smart Chain I set up successfully and then sent BNB from Binance.us to that wallet. I decided to set up a new Metamask wallet that hopefully would not have the same gliche for ETH, so I completely deleted the wallet and restored it using the secret recovery phase. When the wallet opened, the ETH was not there, and the BNB and Binance Smart Chain network were also not there, and the Public address shown is not the same one that was there before. (Could it be from a previous Metamask wallet I set up but never used and now long gone?) I am a senior and feel I have fallen down a rabbit hole and can't seem to find my way out. I would so greatly appreciate it if someone could help me with steps to restore the wallet correctly where I can see and use the ETH and BNB I put in there. THANK YOU, THANK YOU.

Well, after jumping tons of hoops, it does appear I was able to return the BNB to my Metamask wallet.  The article that helped was this one:  https://metamask.zendesk.com/hc/en-us/articles/360059876052-I-have-sent-funds-from-Binance-Smart-Chain-to-MetaMask-but-I-don-t-see-the-tokens-credited-to-my-MetaMask-wallet .  I haven't tried sending any tokens from the wallet, but I have my fingers crossed.  I appreciate the opportunity to interact with this community.


Glad you solved it, and thanks for sharing the Knowledge Base article that provided the solution!

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.