Missing WETH from metamask to Ronin Wallet


This is the confirmation of the first transaction




yes mine too, stated successful but not appearing on my ronin

You sended 1.5 Ether to Wrapped Ether contract address :roll_eyes: I can’t help you with that.

so what does that mean? im using the bridge to send the asset from my metamask to my ronin via de bridge as well

Hello. 1.5 ether came to my ronin account.

The second transaction of .10 eth is not showing in ronin account.
My question is can I use.10 eth now.
Where can I find that eth.



mine still not appearing on my ronin, its been 21 days :frowning:

1 Like

any solution guys
luigi say if u send ether to weth its gona be lost but all youtuber do it normally so where is the problem do, u lose ur money guys ?

Hi! Has this been resolved? I have the same issue. I sent eth from metamask last September 10 using the ronin bridge. transaction completed in metamask but until now, I haven’t received my wETH. I simply copied my ronin address, no edits.

I also tried importing my ronin wallet to metamask, it’s not there.


I found the solution.

Few days ago, I did same thing.
I just send directly ETH from metamask to address which I modify ronin: to 0x without interating with the Ronin.
Of course, ETH was not deposited into my Ronin wallet.
ETH was transferred to an address on the same mainnet as my Ronin wallet.

The solution is…
Just copy private key from Ronin wallet and add account to Metamask with the key.
I could access to the address and there is my ETH.


Thanks so much your a life saver!!! I send it to my KCC address on Kucoin?

You go to deposit and see your ethereum wallet address on KuCoin I should select KCC correct?
Then I need to send it back using ERC20

I ran out of replies on that question earlier

@StopMi YES you have to use KCC. Test the first transaction with a small amount 10-20$

I don’t have enough KCS to be used as gas for 2 purchases. You only send me .001 KCS IS there any other way or contacting you?

Send it to that Waller address on KUCOIN then am I able to switch it to ERC20 when sending it back to metamask

@StopMi Transaction Fees is cca 0.00005 KCS or 0.000115… :grin: try sending small amount to kucoin

1 Like

What should I put for the gas price I’m so confused, eth gas station saying 111 I don’t have that.

@StopMi this is not ethereum mainet or KCC chain. Fees are small.

I need it now to make 3 transactions how much should I put for gas price?

@StopMi OK test Gas Limit 200000 and Gas Price 3 :upside_down_face:

Thanks you so much so the test amount went through. But it’s showing up as KCS not eth in my KuCoin account

@StopMi I sent 0.0001 KCS :upside_down_face: your transaction is still pending

cancel the transaction and try Gas Limit 200000 :slightly_smiling_face: on a small amount ETH


1 Like

Had to make a new account to respond it says it’s pending. I think i didn’t have enough gas and needed more KCS. How do I recover my eth. The other is queued, I tried to cancel it would not let me.

Please is there a way I can contact you, other than this where you can only reply twice then have to make a new account.

What do I do I’m so confused. No ones customer service responds. Know one knows how much KCS you put for gas so it goes to KuCoin. Plus which wallet address.