Multichain - What happened to my Eth? Is there a way to get it back?

Hi, yesterday i tried to bridge the Etheruem Mainnet too Arbitrum on MetaMask, by using the Multichain bridge. I confirmed the bridge on Multichain (0,3 Eth) just too later discover, multichain got hacked and their service is unavailable.

I’ve checked the transaction and it was stuck on “Confirmation” the whole time. Today i’ve checked it again and i couldn’t see the transaction now on Multichain, even if i tried to the Multichain explorer with my adress, there is no history. On etherscan however you can see it.

So my question now is, is there a way to get my Eth back or atleast check what happened too it?


1 Like


It is lost :sneezing_face:


Hello @Banause , visit their social handles . I think there service have been suspended and it’s indefinite. You are advised not to use the service for now or else your assets will be lost . Stay safe

1 Like

Hello, do not use Youtube videos on how to bridge WETH to ETH explanation of HASHRAPTOR. He is suggesting MULTICHAIN bridging service. Unfortunately I used it on August 4th and lost my 1.158 WETH. Scammers are really disqusting

Why are you using bridges to begin with? Its just dangerous period

This topic was automatically closed after 30 days. New replies are no longer allowed.