NFT image not showing in MM

Hello MetaMask community,

Recently I purchased a number of crypto stamps (ERC-721) from the Dutch postal service. Google PostNL crypto stamp if you want. These stamps have a QR code and 12 word seed with which you can transfer them to your own wallet on Polygon.
In this printscreen you can see these NFT in my wallet

When I look on my computer in MetaMask in the portfolio dApp I see the NFT, but without the correct image. Also when i connect to Opensea I do not see the NFT image there. Check this print screen of my MM portfolio.

I have tried several things: read the FAQ, have cleared my cache, thrown away cookies etc, removed MM and added it again, activated auto detection in MM. I also tried the zapper fi website which was suggested in another similar NFT topic. On that website I do not these NFT at all

I am out of ideas, does anyone have a solution for this?

9 Likes

Hello @CryptoDutch, welcome to MetaMask community!

Have you tried adding them to your MetaMask wallet app manually by their contract address and ID? It’s also notable that if the NFTs’s metadata is not in a supported format, you won’t be able to see them. Check these articles for guidance.

7 Likes

Hello @Chinzilla thank you very much. I used the link you suggested and imported the NFT in my MM wallet as a custom token…
You can see there are 10 NLCS (Netherlands Crypto Stamp) in my wallet, but stil no images :frowning:

4 Likes

You can’t see NFTs in your MetaMask extension. Only in the MetaMask wallet app.

3 Likes

Hey @CryptoDutch, welcome to the MetaMask community! :fox_face:

It is likely because the metadata is not supported the Portfolio dapp, and MetaMask extension doesn’t not support NFT view yet.

Here is more information on our Knowledge Base:

6 Likes

Just to be sure, you mean the Andoid or Apple app omn my tablet? That would show the NFT correct?

1 Like

Thank you. On Opensea I see lots of other Crypto stamp NFT displayed correct. How would those owners do that? Use another wallet?

1 Like

Correct, NFT display is supported on mobile devices.

2 Likes

The NFT may display on Opensea but not on the Portfolio dapp because of it not supported the metadata.

1 Like

@nakedwinnie @Chinzilla It worked! I installed the MM app on my tablet and imported one of the NFT’s and this time I saw the NFT correct. You are heroes, thank you so much. Have a nice weekend.

3 Likes

4 Likes