No Notification-Window any more?!

Hello Forum, maybe some expert can help with some strange behaviour:

Since a week or so there is no MetaMask Window opening any more.

One always has to click on the extension-icon in Chrome-Toolbar to open the the small MetaMask dropdown/poput-window.

First I thought it was due to a specific browser setting on my system.
But now also friends report the same problem.

Strangely the problem does not happen with Vivaldi.
But it does with most current version of Chrome.

I tried to go through Chrome and MetaMask settings. But found nothing.

Otherwise MetaMask works fine.

Any idea what to do? :thinking::question::thinking:
Working this way - without an automatic window opening & having to click on ChromeToolbar all the time - is just a nightmare… :dizzy_face:
Thanks a lot for any help!!

1 Like

hi @Anotherbrick . welcome to MetaMask community.

Disable MetaMask in the browser’s extension management interface, and then enable it. Will this work?
Maybe you can paste a screenshot (with private information hidden) so that we can visually see the problem you are encountering. :face_with_monocle:

1 Like

I already have disabled/re-enabled the plugin. Even de-/reinstalled completely in the meantime.

I don’t know how to screenshot a window, which is not opening.

As said, there are simply no MetaMask Windows automatically opening any more.
I have to click on MetaMask-Icon in Chrome-Toolbar to see the tiny dropdown/popup-window.

As said, other ppl are experiencing the same problem recently (~ 2 weeks), so the issue can’t be specific to my system.

Maybe some combination of chrome & OS (Windows 10/11) settings, which prohibit MetaMask behaving as it used to do. But there aren’t many settings in chrome; I already tried to change almost everything.

I’m at a total loss here, as there is no error.
It’s just different behaviour.

It would be best if you contact Support team at https://support.metamask.io and click Start a Conversation

support

Once you click Start a conversation a live chat bot will appear on your screen. It will give you an automated response at first, but afterwards you should be able to contact the support team directly.

2 Likes

Status update:

  • MetaMask support couldn’t help (I didn’t spend too much time with them, though; just giving default recommendations: reinstall, clear browser data etc.).

  • I saw the problem happen again on a clean install. I realize, this happens very rarely, but it’s definately not specific to my unique os/browser configuration.

  • => moving on to other wallets (much better user experience and GUI anyway; just annoying, a few websites still require MM sigh).

Further Status update:

This is a known bug (existing for several months).
See e.g. [Bug]: Extension window doesn't popup on request · Issue #13590 · MetaMask/metamask-extension · GitHub
Well, it’s known to users, not to MetaMask support team.

Seems, the bug is related to the MONITOR configuration! :see_no_evil:

This just shows once again the (IMO) mindboggling incompetence and amateurish level of software development at MetaMask. Only reason it’s still on the market IMO: extreme first-mover-advantage.

  • I wasted/spent a lot of time researching this.
  • Still no solution.
  • MetaMask Support had no clue whatsoever about a bug which was reported months ago.

Just disgusting.

Anyway. :crazy_face:

1 Like

Sorry to hear the issues continue. To clarify, looking through the GitHub issue the MetaMask team is aware of this.

Was a support ticket created for you?

a) The “support”-team I was talking to, had no clue whatsoever.
It should be renamed to “wasting people’s life time”-team. My 8 year old cousins have a deeper knowledge about coding and wallets.

b) Yes, true, some MM team members seem to have been informed about the bug.
All the more disgusting, that nobody seems to care about tackling it.
My assumption: As it’s a rare bug, it was intentionally left unsolved.

[BTW: Just out of curiosity I looked a bit deeper into the issue: Seems this bug has a long history in slightly different variations, going back to at least early 2020, surfacing in different browser versions at different times. A testimony to amateurs trying to code…

And no, I won’t waste any more life time any more with this.
In my many years in software design and consulting I rarely saw a project with this low level of code quality. A browser plugin is not rocket science. So many years since v1 and still on the level of a first year student’s weekend project.

As said, only on the market due to heavy first-mover-advantage IMO.

And no, I’m not alone, many experts in the space wait for a potential airdrop - to delete it instantly after that.

Forgive my tone, I’m writing this after noticing, that the bug of confusing native tokens when calculating gas, has STILL not been solved.
Thanks God, this kind of so-called ‘developers’ don’t work at Boeing or Airbus… ;-D

Sorry to hear about the frustrations, but please remain respectful on our forum. The MetaMask team is a dedicated team of several full-time engineers that are highly qualified. Developing a Web3 wallet to the extent that MetaMask is at today is much more complex than just a simple weekend project. As with any software product, there are bugs and the team is consistently working on solving them.

1 Like

I didn’t say, a wallet would be a weekend project.
I said, IMO the quality of coding (and GUI!) resembles the quality of first-year students doing a weekend project.
As said, I wouldn’t enter a plane any more, if I knew, the software was designed by ‘devs’ of the kind working at MM. Just my two pence ^^

This topic was automatically closed after 30 days. New replies are no longer allowed.