Opensea Error that said "Transaction Failed" actually went through

Attempting to purchase an item on Opensea, I received an Opensea error that said, “transaction failed.” So I tried the transaction again. Everything worked fine that time.
The problem is that the first transaction actually went through. So I ended up with two NFTs when I only wanted one. Here are the two transactions:

Please help.

1 Like

Hello, it’s likely that you clicked the purchase twice in a row during the first transaction, resulting in two metamask confirmations. You may have clicked twice during the final confirmation, so the first time is actually successful, but the second time will show failure because it is based on the first click. This is normal.

4 Likes

This has happened repeatedly. Since the post, I’ve accidentally transferred two items instead of one, twice.
I’m using an external mouse, and I’ve never had accidental double click behaviour on any other website, extension, or application on my computer.
How can we test whether your theory is tue or whether there is a bug in the Metamask Chrome extension?

In this case, you should check the activity record of the block. If there is a display on the block, it indicates that the transaction has been completed. Due to the instability of the polygon chain, it is possible for metamask to return an error. However, as long as there is a record on the block, don’t rush to try the second purchase.

1 Like

I’m not sure why my wallet, Metamask in this case, wouldn’t check the block for me. Why can’t Metamask correctly interface with Opensea, the most popular NFT platform?
If Metamask cannot complete these simple steps, it should inform the user during the transaction.
So how are we going to resolve these lost NFTs?

Blockchain itself belongs to the early stage and is full of uncertainties. As users, we need to constantly learn to solve various problems. I believe I told you this time that you will check the block to confirm whether the transaction is really completed in the process of trading in the future. For the lost NFT, you can contact opensea platform, because you purchased NFT through opensea platform, and the other party also charged a certain fee, They are obliged to help you deal with this multiple purchase caused by technical failure. :grinning:

3 Likes

I will contact Opensea, though I’m sure they will direct me back to Metamask.
As a professional user experience designer, I can assure you that you cannot “blame the user” everytime. If the user is expected to complete actions outside of the Metamask extension, it is the responsibility of the application to notify the user of what it expects of them and to provide the information needed to complete the actions.

I don’t mean to blame the user. The community also wants to help you solve the problem. I find that your gas is very low, which may also matter, because every time I use polygon chain interaction, I will manually adjust the gas to the maximum, so that I can make a quick transaction, and there are few problems. You can also try this. If the same situation still occurs, please raise it again and I will convey it to the team for you, Thank you again for your report. :slightly_smiling_face:

2 Likes

Sadly, this is not the first Metamask bug I’ve run into - Advanced Gas Control UI Bug - No Failed Transaction Justification

I don’t use Metamask’s advanced gas controls because of the $200 I lost when Metamask failed to show me a readable error message.

In many cases, we need to be careful in every step, and the same is true in the trading process. The use of advanced gas control in polygon chain can ensure the smooth interaction. When we explore blockchain, we can avoid unnecessary losses, including gas lost in your previous transactions. In fact, this is also easy to happen in block trading, because gas is also dynamic, Various factors will affect the success rate of the transaction itself. :smiley_cat:

1 Like

Hi,

Wanted to share I saw this on the Polygon site. You should verify links yourself by going to the legit Polygon site and locating support of their page, this way you can be sure you’re not going to a scam.

Thank you, but I’m afraid the transaction did not have inconsistent data between the extension and Opensea.
I’ve contacted Opensea and am currently working out whether Metamask is to blame or not.

So what’s your issue with it?
Do you want one to be taken and your money refunded?

This has happened three separate times: One double purchase, two double transfers.
Realistically, recovering NFTs is probably problematic.
I think a good solution would be to get credit to pay Metamask fees. Over time, I would recover my funds.