Seed phrase but no private key

Right I’ve spoken to loads of people about this but still no progress. I was logged in on metamask on my old phone and face id stopped working. I have a new phone, logged in that account on my new phone and it opened up metamask (showing all my ETH transactions history) but a completely different wallet address.
I don’t have private keys but have 12 word seed phrase, I desperately need someone to help me here. I will genuinely travel across the world to buy you dinner just someone elaborate on how to get this back please

I’m not sure you’ve given enough info to help you, partly because what you have given seems to contradict itself somewhat but I’ll take a swing here.

IF you have your seed phrase (12 words) and metamask accepts it than the wallet created MUST be yours. They derive from some algorithmic math and it’s pretty damned close to if not absolutely impossible for the seed phrase to work and you get a wrong address out of it.

Further, you say you see the transactions history. So are these YOUR transactions? (ie are they correct and match up to what you expect?)
If so I’m hard pressed to think you have the wrong wallet address.
One thing you can check imo is take one or a few of the transactions you accept as correct and look them up on Etherscan. The address they were sent from/to will be shown and is incontrovertible and should (will) match with the Metamask address.

There is one other possibility I can think of that I’ll throw out there in case it’s what’s going on.
When you use the seed phrase to restore a wallet it only restores the FIRST wallet address (what Metamask calls “accounts” within the wallet) that was created. If you had created additional of these “accounts” they are not automatically restored. You can pretty easily restore them by clicking “Create Account”, once for each of the accounts that you had / need to recreate. Meta will NOT remember the names for these, you have to name them again.

Personally I think it’s a fairly dumb way to handle it (and I actually came here to post about just that) but I’m guessing it might just be where your “missing” wallet address is “hiding”.

DM me if you intend to keep that promise of a nice dinner :wink:

1 Like

Yeh think you’re right, someone else said this to me that it obviously is my address but not the one I had all my stuff on. So you think I could keep clicking new account and it would just appear, or would need to import the old address because I won’t be able to import it

Please make sure you are correctly inputting the right Secret Recovery Phrase for the wallet you are trying to access. Here is more information on our Knowledge Base:

I have a similar problem. My metamask app crashed on my iphone, it wont load. Although I can still connect to uniswap and pancakeswap on safari browser. Im scared of deleting the app because Im afraid I will loose everything.

I have my seed phrase and I tried to recover access to the wallet on a different phone. But it says invalid seed phrase. However if I type my seed phrase backwards it will grant me access to a new wallet. Im devastated as I have all my crypto there, and I cant find any live agent to help me sort out this issue. Please someone help me!!!

Hey @BB_gman, please refer to the article above as to what could be the issue.

Please make sure you are inputting your Secret Recovery Phrase in the correct order and for the correct wallet address. For example, people often make the mistake of typing the words in a column when they should be typed in a row.

1 Like

Hi @BB_gman if you are afraid of your data :point_down: here is a guide for iPhone backup

Then you can find yours MetaMask Vault Data:

5 Likes

Mate I’ve lost mine and no way back. Fuming!

Have you tried using the Vault Decryptor?

I don’t understand how to do this, and i’m on mobile?
I need to meet someone in person and help my i’ll pay for services.

You can do this on mobile on iOS by hooking your device up to a computer, here is more information with the steps on our Knowledge Base:

You can try to see if someone would like to meet you in person to assist you, but please be very careful of scammers. You should never give away your Secret Recovery Phrase, and because your phrase will be revealed at the last step of the Vault Decryptor recovery, please make absolutely sure that this is not shown to whoever is helping you.

1 Like

@Luigi could you please help me with my issue? I don’t have my recovery phrase and my Metamask encountered error with data storage on iOS mobile. I only use Metamask on my IPhone. I have followed the steps on vault data retrieval: backed up my iPhone to my Mac, found the persist-root file in metamask but when I copy and paste the JSON object of the “Keyring Controller” nothing changes. It just shows the same thing. There is no cipher. Please any help is much appreciated.

Hi @Roor hmm :roll_eyes: my problem is that i don’t have an iPhone :smile: so i don’t know how that guides works.

2 Likes