[Sending/Recieving ETH & Tokens] Goerli ETH balance does not change despite succesful transactions appearing in activity

Two days ago I’ve requested 0.5 Goerli ETH to my Metamask wallet at goerlifaucet[.]com . The transaction has appeared as confirmed in the activity tab of my Goerli account at the Chrome web extention (as well as in the block explorer), but the overall balance did not change. I downloaded Metamask mobile app and imported my wallet - there it showed the balance correctly. Today I’ve requested another 0.5 ETH. They quickly appeared on mobile version after being confirmed by the chain, but on the desktop the transaction didn’t even show up in activity. As for now, I have 1 Goerli ETH according to the app and 0 according to the extention.
Thank you for your help.
P.S. Just tried importing my wallet to Firefox extention and everything showed up correctly. I don’t need help anymore, but even so, I think that this report may be of interest for you.

1 Like

It seems like I actually do need help. I wanted to use Metamask in Umee testnet simultaneously with Keplr wallet, and Keplr is only aviable on Chromium. I tried importing my Metamask wallet into Brave browser, and the problem is the same as on Chrome.

1 Like

Hi SweetieBlu;

Welcome to the MetaMask community :fox_face: by any chance, is the 0 balance showing up on Chrome or Firefox in orange?


No, it’s showing up in black everywere.

1 Like

I figured it out. When I granted Metamask the permission to read and write on all sites, the balance changed to correct. Thank you!

1 Like

Awesome, glad that worked!

This topic was automatically closed after 29 days. New replies are no longer allowed.