Speeding up a cancellation

Hi there,
I cancelled a pending transaction because the gas fees that were use were way too low (only 41 Gwei). So I clicked “cancel” in metamask, then selected “high”: metamask set the priority fee to 2, and the max fee to something around 140 gwei. I don’t remember exactly. Then I clicked save.

Result: the pending transaction was dropped, yeah, but now I have the new transaction pending. What I don’t understand is that this new transaction has a gas price of only 45 Gwei?! Metamask definitely suggested a different price which I did NOT touch.
OK, so I tried so speed up that and clicked “speed up cancellation”. I selected “high” again and additionally increased the priority fee to 3 (!) and even increased the suggested max fee a bit.
This sped up transaction is now pending, too… What the f***?!? Gas price in this transaction is indicated on etherscan as 49 Gwei?!? How come that? Why does metamask only increase by a ridiculous 5?!

What can I do in order to make the transaction go through? Should I insert 1 million into metamask in order to make sure that an appropriate value for the price gets through?

Can anyone help? Thank you very much!
Mat

1 Like

Hey @Kingfisher80, sorry to hear this issue is occurring :frowning:

Not sure why the gas price was set that low, I would suggest restarting your browser and hopefully that may help. You can manually adjust the gas settings so that your transactions do not end up pending, here’s some more info on your Knowledge Base:

For your current pending transaction, please refer to this article on our Knowledge Base:

1 Like

Hi @nakedwinnie,

thank you for your immediate answers. The links you sent me just show the standard procedures which am already aware of.
I can show you step-for-step what I did and what my metamask looks like.

This is my transaction history:
0xb182583eb2b4cda79db429d68c9a4b9eb3251a50

I already succeeded in cancelling a pending transaction (nonce 2) with the help of this transaction: 0x5939c8188a9f61636c711eeafce25227f26b4758617139d15e81251938a6352e (nonce 2)

As this did not go through I tried to click “speed up this cancellation” and now I have another pending transaction, i.e. this one:
0x2c13fb1830bd0b1e5f82b4a223ff950ac5ba2dd66fca3a98b14820dca0c6a29b (nonce 2)

I can click again on “speed up”:

Then I will get this screen:

Here I click “high” and get that screen:

When I click “save” I’m sure I will get another pending transaction with a gas price of only a few Gwei more than the 49 of the previous, pending transaction. Why does etherscan not take the 141,248293367 Gwei I can see in the metamask window below (max fee).

Why does it show 0,00 USD on the right?!?
I already tried clicking the small arrows and increase the max gas fee. This will look like that:

Then a USD price will appear. But after clicking “save” the Gwei on etherscan only increased by a meagre 5 Gwei compared to the previous transaction.
Should I do that about 20 times in a row to reach a reasonable gas price of about 150 Gwei!?!?

I also tried to increase the priority gas fee, too, but I did not help.

The only thing may be is, I do NOT have “advanced gas controls” activated in the settings…

I’d appreciate any kind of help. I’m really desperate and do not know what do to.
Restarting the browser did not help. Resetting my history is what I won’t do as the transaction is still pending on etherscan, so no metamask glitch.

PLEASE HELP

Kind regards,
Mat

Thanks for sharing the images, those were very helpful!

Please make sure you have advanced gas controls in your settings ON. There’s more information in the Knowledge Base article I linked above. This is likely the main source of the issues.

Etherscan shows the Gas Price in gwei of the actual cost of the transaction, not exactly the max fee that you inputted in MetaMask.

The Max fee is currently set to a very high price, which is likely causing a UI error. The comma is likely supposed to be a period - 146,665763869 should be 146.665763869

1 Like

Hi @nakedwinnie
thank you so much for your help.
No I tried to speed up again, advanced gas fee is activated.
I used the high speed recommendation as an orientation.
I entered manually these figures:
max priority fee: 3
max gas fee: 150
Metamask told me the transaction will likely be competed within less than 15 sec.

When I look at etherscan it recorded the transaction with a gas price of 54 Gwei!?!?! Why the hell so low? The gas price has never been so low in recent weeks.
However, after the 3rd speed up gas price value on etherscan has increased by 5 Gwei each.

Do you think I can “play this game” until the gas price reaches a sufficient amount? Or do I have to pay for each single speed-up process? So far I have paid nothing.

Thank you
Mat

Are these transactions still pending though? I would wait until they succeed and see what the gas prices looks from there.

Yes, I have 3 pending transactions. I attached a screenshot below. One has nonce 3 (that’s the withdrawal) and the other two have nonce 2 (these are the two transfers) After several hours, the previous transaction is dropped and only the most recent sped-up transaction remains pending, as you can see here.
I sped up 6:47 hrs ago and 58 min ago. The speed-up I did about 8:30 hrs ago has already been dropped, I guess the one from 6:47 hrs ago will eventually be dropped, too.

Each time I speed up the gas price in metamask, etherscan shows an increase by 5 Gwei. Now I’ve reached a gas price of 54 Gwei and I started with 41 Gwei …

I just don’t know why the transaction does not use a realistic gas price on Etherscan? Do you have any idea why? Metamask keeps telling me the transaction will be completed after <15 seconds. Etherscan, however, tells me > 1 hour … it’s kind of frustrating.

Best regards

Sorry to hear the issue persists :frowning:

As to why Etherscan is showing a much lower Gas Price than what is current, even after you set the max gas fee, I’m honestly not sure.

If you would like, please submit a ticket to our support team here:

https://metamask.zendesk.com/hc/en-us/requests/new

Thank you for your patience and your great support so far. I’ll submit a ticket…

One idea: I only want to cancel/speed up this transaction (nonce2) in order to get through/complete the withdrawal (nonce 3).

Couldn’t I just cancel the withdrawal itself, create another metamask account and then start the withdrawal to this new metamask account? Or can’t I cancel a transaction when there is a pending transaction with a lower nonce…