Spinning Wheel when approving on second contract(NFT)

Hey all. Having a problem I have tried three different browsers with no change.
So what is happening:
1.) I have a NFT contract deployed on Rinkeby and a marketplace contract
2.) This contract lets me approve the marketplace contract
3.) I deploy a new NFT contract
4.) I cannot approve the marketplace contract on new NFT contract
5.) I just get the spinning loading circle and nothing else

I also tried to deploy fresh marketplace and fresh NFT contracts and the same thing is happening, I get the spinning circle.

The original NFT contract lets me approve on the marketplace that i deployed a few days ago, but if I try to create a new NFT contract, I cannot approve on the marketplace.

1 Like

The approve function works locally on remix but once in the wild, it does not work

1 Like

If someone could try and see if they get the same spinning wheel as I do, you can do this:

mint nft from rinkeby write tab:
0xb60C69451C7def1C3959331EC81410E6ae0bDafC
token amount: 1

check your nft id# with your address on the read tab, function tokensByOwner will give you your mint#

back to top of write tab:
open the approve function
type in marketplace address 0x7c8a64e8035E40dB936904aB7145F35152c0859d
and your token id from the tokensByOwner function on the read tab

I keep getting spinning circle

1 Like

Update:
seems to work on android mobile metamask but still does not work on pc with windows and chrome with updatated metamask after reinstall

1 Like

nft write contract:
htt**ps://rinkeby.etherscan.io/address/0xb60c69451c7def1c3959331ec81410e6ae0bdafc#writeContract

contract to approve:
0x7c8a64e8035E40dB936904aB7145F35152c0859d

Would you be able to send a screenshot?

Looks like you said it works on mobile and only not working on extension. What version of MetaMask and browser + browser version?

1 Like