Swap Failed: Unknown error: "Error: [object Object]"

For 2 days now I am unable to transfer funds between my hardware accounts or convert ETH to Poolz on Uniswap via my Metamask chrome plugin.

I have enough ETH to execute the fastest transaction on ERC-20.
I have set up slippage limit of 10% (just in case)
I have restarted my machine
Reconnected my Ledger Nano S and Ledger Live (as the wallet bridge)
Tried transferring between accounts on Metamask but failed (was able to do this on Ledger Live though)
Tried converting some ETH to Poolz as well but failed.

Flow:

  • My cold wallet is connected via usb and Ledger Live is up and running
  • Open Uniswap website
  • Trying to convert 0.256 ETH to 130 Poolz
  • Set up 10% slippage, auto route, expert mode on Uniswap
  • Metamask pop up window shows the expected fee and I confirm
  • The Ledger Live bridge pop-up message appears and I click on ‘Open Ledger Live’
  • Approve opening a web socket between Metamask and Ledger Nano S
  • I get: Swap failed: Unknown error: “Error: [object Object]”. Try increasing your slippage tolerance. Note: fee on transfer and rebase tokens are incompatible with Uniswap V3.
  • On Metamask activity I get ‘Exact Input Single’ but am unable to click through and view of ETHscan

I truly appreciate your help

Thanks

7 Likes

Hey, I’m experiencing the exact same issue with the exact same setup.

Were you able to get it resolved?

Same here.

Could you solve it somehow?

Solved.

I had to update Ledger Nano Firmware to the newest version, downloading again from the manufacturer´s website

1 Like

Hello, wich version of the firmware are you using please? I updated mine to v1.6 and still have the same issue.
Tks
J

I experience the same thing. But I was able to do 1 swap yesterday, after a few hours I couldn’t do any more swap. Same on Brave and Chrome. Other functionalities like Ledger Live, sending funds…seem working fine with my Ledger.

I updated my ledger to V2.0.0 and still not working… Some of you managed to make it?

Having the exact same issue, Worked for 1 transaction earlier yesterday and noting is showing up to confirm on my ledger. Extremely inconvenient and annoying to deal with.

Ledger Live says firmware is up-to-date for my nano X. It’s at version 1.3.0 right now. smh…

Is 2.0.0 even out yet?

V2.0.0 is for nano S

This can be solved by allowing contract on the ledger device again.
In my experience, contract data permission was changed after updating ledger nano.
It’s worth to check “Settings > Contract data”.

2 Likes

Did that. Doesn’t work.

Ended up ditching MM for ledger live mobile. Unless they address this issue soon I won’t be back to using it.

1 Like

Hey i fixed the issue… I had to reinstall the ethereum app then turn contract data off. Having data contract off did not fix my issue until after i reinstalled the ethereum app. Prior it was behaving like contract data was turned on even though it was turned off.

Hope this helps.

so far I have reinstall mm, reset account in mm, reinstall ethereum app and nothing have worked

I am having the same issue. Updated firmware, contract data allowed and still nothing. Won’t bloody work

I’ve managed to swap on MM from another computer. Also, I don’t have any issues swapping BSC based tokens on MM. I still don’t know why my main computer is failing to swap ERC-20 based token on MM

i have the same problem ¿why not metamask update extensión and solve this issue???

2 Likes

Same issue here, on Avalanche Network.

Guys ,
Go to Etherium - Settings on your Ledger device and Allow to Contract Data.

2 Likes