Failed transaction [object Object]

I try to use my Ledger via Metamask and the transaction alsways failes. Wether its on Eth or on bsc.
I used it a 100 times before but now I get the error. My Ledger it self works and I use Chrome cuz its the only browser Metamask works properly normaly.

Thanks for helping

I am also facing the same problem. Not able to send tokens out of metamask. I have connected my ledger to my metamask and only the BEP20 tokens which are not supported by ledger live are not able to be withdrawn. please help me out anyone, i have tried reaching out to the metamask team they dont even respond to my mails.

Same problem here. Ledger live + metamask extension in Mac
After I tried to use Metamask Swap, I faced this error.
I reintalled metamask and update ledger 's farmware and leger live. but an error occur

i got a same issue with matamask, i couldn’t swap it said trasection error object object i dont get how can i solve it. i still can use to trafer to other walltet

I also have this kind of problem. This problem occurred only after i updated my Ethereum app to the latest version on the ledger. Anyone - please help!

Edit:
I got it! Just go to your ethereum app, then go to Settings, then go to the left. U’ll see: “Contract data Not Allowed” → just change it to “Contract data Allowed”. Voila!

4 Likes

I have the same problem… I haved check on “Chrome, Edge and Firefox” nothing run!
Exactly same error, with my ledger device.
The same way on KCC,MVR,ERC20,BEP20,AVAX.
Yesterday everything was going normally.
I need help please.
I wrote to the support but nobody wrote me back…
PS: I used this way of doing from minimum 6 month ago on ERC20 and BEP20, less for the others blockchains.
Thanks in advance.

I had the issue but i managed to FIX IT

  • Go to your App on your Ledger
  • Go to Settings
  • Change to “Contact Data Allowed”

This should solve it

I did that and the problem persists. I have unplugged ledger and plugged it again too.

Hello everyone, has anyone managed to find a solution to this problem? impossible to transfer funds, swap, however I can enable us to contract …

Still no solution for me. I have restarted my computer, my ledger, everything. However most people seem to be fixing this by allowing contract data, which is definitely not working for me

1 Like

hey not sure if this helps but my ledger also kept giving me this error today even when i changed to contract data allowed. I solved it by reinstalling ledger live on the ledger website as although it said i was on the latest update it actually wasn’t. i reinstalled the apps and then changed to allow contract data as it changes to not allowed after the update and now it works.

I have the same issue, which cannot be solved by changing contract data “Allowed” nor reinstalling the Ethereum wallet. Also, I figure out that this problem only occurs when doing with BUSD. It works fine with other tokens such as cake, bnb.
Do anyone have the same problem?

Same problem since 2 weeks, only on binance chain. Cannot enable any token on pancakeswap - i can swap BNB vs lets say USDC, but i cant enable USDC to swap back to BNB, neither can i send the USDC - object object error.
Polygon/Avax/ETH chain works just fine. Contract data allowed, all apps/ledger/chrome up to date. Tested brave and firefox as well, same problem.

Your ledger live is desktop version, not mobile app?

Same problem, tried:

  • upgrade ledger live desktop app
  • allow contract data
  • turn off/on everything

Nothing appers on the ledger and I can’t confirm the transaction

Not tried yet: other browser (I tried on Brave)

Dude, thank you… :pray:

.

Have the same issue. Also BUSD. I know others solved through contract data setting, but mine is ON, has been for a long time. If anyone finds a solution please let us know! I tried sending busd to binance exchange and also fails

Hey everyone I was having this issue and found a fix.

Step 1! Go to ledger live and update.
Step 2! Go to your eth app and reenable contract data ( you will need to do this even if you had it on before, it resets after update)
Step 3! Go about your transactions like normal.

1 Like

effectively update the ledger live application directly via the manufacturer’s website. Then you will have a big update of the Ledger Nano X to do and you will be able to resume everything correctly :slight_smile: Thank you very much.

this problem has nothing to do with ledger live update, there is a bug in the latest MetaMask extension update

i have installed a fresh MetaMask instance and a completely fresh, latest LedgerLive on Mac OS Chrome/Firefox, Windows 10 Firefox/Chrome and nothing helped, neither the Ledger live connection, nor classic connection that requires authentification

what you really need to do is to uninstall metamask completely and install an older version of MetaMask

version Version 10.0.3 is the latest one that does not have this problem
github.com/MetaMask/metamask-extension/releases/tag/v10.0.3

so, export your accounts, uninstall extensions, go to chrome://extensions/, click “Developer Mode”, Load Unpacked extension, restore your old accounts/connect hardware wallet

that’s it, the old version doesn’t have this bug

eidt: it turns out the ledger live claims it has the latest verison installed, even though it doesn’t. so make sure you go to the ledger live site and manually update!

considering how silently metamask updates in the background, this was a massively irresponsible move by MetaMask

1 Like