Swap WETH to ETH but it's gone

I tried to swap WETH to ETH through MetaMask swap, but the WETH got burned, i didnt received any ETH back.

I tried to contact MetaMask support but it’s no luck

Txn : 0x6064c7a864f78315c9578bd3b1723a340294d14419aaa6b8c346d7ceb36bb877

Can anyone help on this?

1 Like

hey @oongok , it seems that 2.4 weth returned to your own wallet after the transaction.


the 0000 is not my wallet, it was 6ec7. so it’s stucked on 0000 @tuya

1 Like

Can you check in your opensea account? As per debank, this transaction is related to opensea

If you have not got returned anything NFT/ETH for your matching orders in opensea, can you also kindly consult with opensea first?


I already try to consult to opensea @Mandip , but they said that I need to contact to wallet provider since WETH are completely burned sucessfully when converting to ETH.

But at 1st places I’m confused, why MetaMask swap interacting with the opensea, which I still confused at the moment, because I simply use the MetaMask swap

1 Like

Hi @oongok , Please contact with the MetaMask support team.

Remember - NOBODY, including from support, will ask for your secret recovery phrase / private key or for you to input it onto any website for confirmation.


@Mandip thanks for this, but I already doing that, but it’s still ongoing discussion, I also got an update from opensea that matchorder are not function from opensea

1 Like

Please wait patiently for reply from the MetaMask support team if you have not received. If received, kindly follow the instructions provided.


This topic was automatically closed after 30 days. New replies are no longer allowed.