Tx blocking my next txs, can't cancel it. Money stuck!

It appears this tx 0xe21e12a8a4fece9e64e501e74b24a1d240706dbf5613b7c188968bf15cc66fcf is blocking my next txs, my money is locked in my account. I can’t cancel this tx either, I tried setting a tx with custom nonce but it’s giving me an error, the tx doesn’t happen at all.
I resetted the tx history so now I can’t see any of the outgoing txs, however none of them got canceled. Now I know it was a mistake, the tx WAS actually on the blockchain, I shouldn’t have resetted the wallet, but now UI doesn’t show the tx so it seems there is seemingly no way to cancel it.

I realized this problem yesterday when I made a new tx where I tried to purchase an NFT. The tx is not showing up in my metamask wallet and the amount didn’t get substracted, however I have the txid, the market got notified about the incoming transfer, the gas fee is sufficient and it’s still not going through, as I said, it’s being blocked.

What do I do? The blocking tx is very old, if I remember correctly it was some meme “project” that rugged, not sure why it didn’t go through, though.

Thank you for your help

1 Like

Hey @zlvr1338, sorry to hear this is happening!

Can you share screenshots of what is appearing when you say your transaction is being blocked?

Transaction 0xe21e12a8a4fece9e64e501e74b24a1d240706dbf5613b7c188968bf15cc66fcf is already cancelled according to Etherscan.

I’m not sure how that happened but that tx did get cancelled and the following txs all went through, so everything’s fine now :slight_smile:
Anyway, thanks @nakedwinnie

1 Like

Hello,

thank you for your help, the tx got canceled and the rest all went through, everything is fine now!

Regards

zlvr

1 Like

0xa6e42bef912a45e2adced576e92d9e3190a8db7960c4260657dcc5bba019fb6b
0xa0e335a36a7af399fe9d4c8bd35b0bbf0ffc6c771278f1d2bbde846c80bea088
Both ETH payments I sent to Coinbase I never received my money please help me. It says success but I never got no money.

Hey @og315, what network did you send your ETH payments on? I have searched 0xa6e42bef912a45e2adced576e92d9e3190a8db7960c4260657dcc5bba019fb6b and 0xa0e335a36a7af399fe9d4c8bd35b0bbf0ffc6c771278f1d2bbde846c80bea088 but nothing is appearing.

Hey everyone. I’m new around and I don’t find a way to open a new ticket.
That said, I have a pretty similar issue.
I bought an NFT on OpenSean (done many times with no issues) but this time for some reasons 2 transactions were created:
1 - successful - 0xf1afe4eb360f00c742192c147935118d87756907ad9f09787400a9dd6244fa38
2 - stuck - 0xa4ee107730bde3a6664c246574d73adb573c17d7734ea67adf653c6a0f572059

The second transaction does not seem to exist in etherscan.
Now, even if I have money to cancel it, MetaMask does not give me the option to.

I attach 3 screenshots from MM extension.
1


Any help is appreciated!

1 Like