Unable to send USDT on BSC

I created the BSC network in Metamask and transferred BNB to a wallet. The transaction was completed. But when I tried to transfer USDT, the transaction fails. Binance writes that the transaction is in processing but bscscan does not see it. Almost 4 hours have passed since the funds were sent.

Hello, see yours BNB in Metamask wallet? You use BEP20 for send BNB?

Welcome to the MetaMask Community @saavtr!! :fox_face: :rocket:

Are you sending the USDT to or from your MetaMask wallet? Do you have sufficient BNB in your wallet to cover the gas fee?

When you say, “the transaction fails” are you receiving an error message or is that the status of the transaction on BscScan?

When I am trying to do with bnb in wallet . It says total usdt 0 even though it add 6 usdt + bnb as gas fees.

Welcome to the MetaMask Community @Nikhiljain!! :fox_face: :rocket:

Sorry for the trouble with your balance. Can you confirm you’re on the BSC in your wallet? If so, please try the steps found here.

I have tried everything and now my 40 usdt plus bnb are gone. I would request you to either help me recover it or refund me

I’m sorry to hear you’re still having trouble. Please submit a support ticket & we’ll continue to assist you further.