VET tokens not showing up on Metamask and can't be tracked on Blockchain

i’ve tried reaching to metamask everywhere but no luck.

Last night I went to binance to transfer all my VeChain tokens to my metamask wallet. This tokens were supposed to be my money for rent but decided to convert to crypto for a while since I have to pay on the 15th. Everything went smooth on Binance, but when I got to check my metamask, even if the token VeChain is added already, it’s not showing up. I then checked my address on the blockchain, no transaction ever happened there. I’m hella confused as to where my money has gone. I’m so stressed and having an anxiety attack, I’ve tried every option possible on the internet but no luck.

Please, I badly need that money. It’s 10,000 Philippine Pesos. It’s supposed to be pay for rent, I’m poor, I can’t get that money rightaway. I have to work hard for it. Please somebody help me, if I can’t pay, I’ll be getting my notice rightaway.

Hmm :thinking: Hi @KenwithD VeChain uses VeChain network
and MetaMask :fox_face: not support this network.

Enter your ETH address here :slightly_smiling_face: :point_down: and you will see your VeChain token

To fix the problem :point_down: read this post